httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amey Abhyankar <sco1...@gmail.com>
Subject Re: [users@httpd] How to fix HTTP 100-continue from client HTTP 417 error in Apache 2.4.10?
Date Wed, 06 Feb 2019 08:54:23 GMT
Hello Dan,

On Wed, 6 Feb 2019 at 13:05, Dan Ehrlich <dan@ehrlichserver.com> wrote:
>
> Looks like you just need to enable mod_headers (http://httpd.apache.org/docs/current/mod/mod_headers.html)
and then add the below text that they mention in the Stack Over question?
>
> You might need to run “a2enmod headers” from terminal once to get it loaded into
Apache HTTPD forever, but that’s it.
>
> Btw put that text (assuming you’re fine running it for every website on that server)
in either /etc/apache2/apache2.conf. Might be /etc/apache2/httpd.conf can’t remember
>
For me it's /etc/apache2/apache2.conf
So the steps I need to perform =

i) Put below code at end of the apache2.conf file & save it.
ii) Run “a2enmod headers”
iii) restart apache2
iv) Test back.

Am I right?

> Does this help?
>
>
> “
>
> <IfModule mod_headers.c>
>
> RequestHeader unset Expect early
>
> </IfModule>
>
> “
>
>
> On Feb 5, 2019, at 11:26 PM, Amey Abhyankar <sco1984@gmail.com> wrote:
>
> Hello,
>
> I am using Apache 2.4.10 server on Debian 8.11.
>
> I am having following issue = Request sender is sending Expect:
> 100-Continue" in header.
>
> Reference URL suggesting the fix =
> https://stackoverflow.com/questions/3889574/apache-and-mod-proxy-not-handling-http-100-continue-from-client-http-417
>
> How to fix this issue? Thanks.
>
> Regards,
> Amey.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message