httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Ehrlich <...@ehrlichserver.com.INVALID>
Subject Re: [users@httpd] How to fix HTTP 100-continue from client HTTP 417 error in Apache 2.4.10?
Date Wed, 06 Feb 2019 07:35:06 GMT
Looks like you just need to enable mod_headers (http://httpd.apache.org/docs/current/mod/mod_headers.html)
and then add the below text that they mention in the Stack Over question?

You might need to run “a2enmod headers” from terminal once to get it loaded into Apache
HTTPD forever, but that’s it.

Btw put that text (assuming you’re fine running it for every website on that server) in
either /etc/apache2/apache2.conf. Might be /etc/apache2/httpd.conf can’t remember 

Does this help?


“
<IfModule mod_headers.c> 
RequestHeader unset Expect early 
</IfModule>
“


> On Feb 5, 2019, at 11:26 PM, Amey Abhyankar <sco1984@gmail.com> wrote:
> 
> Hello,
> 
> I am using Apache 2.4.10 server on Debian 8.11.
> 
> I am having following issue = Request sender is sending Expect:
> 100-Continue" in header.
> 
> Reference URL suggesting the fix =
> https://stackoverflow.com/questions/3889574/apache-and-mod-proxy-not-handling-http-100-continue-from-client-http-417
> 
> How to fix this issue? Thanks.
> 
> Regards,
> Amey.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 

Mime
View raw message