httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Moskowitz <...@htt-consult.com>
Subject [users@httpd] AH01630: client denied by server configuration
Date Sun, 03 Feb 2019 00:35:04 GMT
I have google around and the obvious reasons for this..

I am working on a new setup with posrfixadmin ver 3.2 on Centos7-armv7 
with SElinux enforcing. Last I worked with postfixadmin it was ver 3.0.2 
and my notes are based on that and Apache 2.4.

My postfixadmin.conf file for Apache is:

alias /mailadmin /usr/share/postfixadmin
<Directory "/usr/share/postfixadmin/public">
AllowOverride AuthConfig
Require ip 192.168.0.0/16
</Directory>

I added the /public on the Directory statement based on the content of

/usr/share/postfixadmin/index.php

when I try connecting to host/mailadmin/setup.php I get:

Forbidden
You don't have permission to access /mailadmin/setup.php on this server.

Checking error_log I see:

[Fri Feb 01 15:40:43.714302 2019] [authz_core:error] [pid 7692] [client 
192.168.160.20:52060] AH01630: client denied by server configuration: 
/usr/share/postfixadmin/setup.php

My IP addr is in the required range, but it fails. I tried opening it up 
to "require all granted" and still no access.

In 3.0.2 I had to do:

chcon -R -t httpd_sys_content_rw_t /usr/share/postfixadmin/templates_c
setsebool -P httpd_can_network_connect on

I noted that the directory is now /templates but the INSTALL.TXT still 
points to templates_c. I have made the change to the above chcon command 
with no results.

What am I missing? What has changed?

thanks



Mime
View raw message