httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Schöning <tschoen...@am-soft.de>
Subject [users@httpd] How to configure a "Location"-block for URLs containing spaces?
Date Fri, 14 Jun 2019 09:50:34 GMT
Hi all,

I'm hosting some SVN-repos using mod_dav_svn and am running into
problems when using URLs with spaces.

My approach is simply to have a directory structure of SVN-repos
grouped by customers or some topic and for each of those groups I want
to configure a corresponding URL as entry point into mod_dav_svn. Some
of those groups contain spaces for historical reasons and because I
want to use 1:1 paths in the file system as URLs, those spaces should
be handled in httpd as well.

The ultimate problem is not with httpd itself, but with mod_dav_svn:
Depending on what I configure in httpd, that is unable to properly
calculate the repo name from an URL. I'm somewhat sure why and where
that problem comes from, but I need to be sure what the correct
configuration of httpd is.

Simply look at the following example:

>     <Location "/svn/Bin/LSG BE-BB">
>         DAV                 svn
>         SVNParentPath       "/home/ams_svn_repos/Bin/LSG BE-BB"
>         SVNListParentPath   On
>         SVNAdvertiseV2Protocol          Off
>         AuthzSVNReposRelativeAccessFile authz
>     </Location>

The URL for the location is configured using a space instead of %20
and the request properly gets forwarded to mod_dav_svn to break there
for other reasons. When the location changes to the following instead,
the request is NOT forwarded to mod_dav_svn anymore:

> <Location "/svn/Bin/LSG%20BE-BB">

TortoiseSVN throws the following error instead:

> Fehler: The server at
> Fehler:  '[...]/svn/Bin/LSG%20BE-BB/GosaPrint/trunk'
> Fehler:  does not support the HTTP/DAV protocol

The interesting point is that the wrong "Location" would most likely
resolve the problem I have with mod_dav_svn not properly calculating
the correct repo from the URL.

So, what is the correct configuration for "Location"?

I couldn't find anything in the docs regarding if decoded or encoded
URLs should be configured. There's only the stange mentioning of
"URL-path|URL", but don't know what that should tell me. Regarding my
tests, I guess the proper thing to use really is the space.

Thanks!

Mit freundlichen Grüßen,

Thorsten Schöning

-- 
Thorsten Schöning       E-Mail: Thorsten.Schoening@AM-SoFT.de
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message