httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Hock <daveh...@johndavidhock.net>
Subject Re: [users@httpd] css files not loading
Date Mon, 10 Jun 2019 13:09:13 GMT
Hello Frank,
     So I tried your suggestion and of course it worked!!  I hope you know
how much this means to me.  I have been looking for a solution to this for
several months and had given up a couple of times.  Thank you so much!!

On Mon, Jun 10, 2019 at 7:54 AM Frank <thumbs@apache.org> wrote:

> Always match the trailing slashes when using the ProxyPass directive.
> The ProxyPassReverse should match too.
>
> On 09/06/19 10:15 PM, Dave Hock wrote:
> > Hello,
> >       I am hoping to get some help with an issue concerning a reverse
> > proxy setup and static files.
> >
> > I have two domains that I purchased from Google Domains,
> > johndavidhock.net <http://johndavidhock.net> and johndavidhock.com
> > <http://johndavidhock.com> and have created very simple websites for
> > both of the domains which consist of a single html file and a css file,
> > index.html and main.css respectively.
> >
> > My home network is setup as follows:
> > Server location: 192.168.1.103 - hosts the www.johndavidhock.net
> > <http://www.johndavidhock.net> site
> > Server location: 192.168.1.104 - host the www.johndavidhock.com
> > <http://www.johndavidhock.com> site
> >
> >
> > I also have a server at 192.168.1.105 which acts as a reverse proxy
> > server and has the following files in the /etc/apache2/sites-available
> > folder:
> > Reverse Proxy Server location: 192.168.1.105
> >
> > johndavidhock.com.conf
> > johndavidhock.net.conf
> >
> > The contents are as follows:
> >
> > <VirtualHost *:80>
> >          ServerName                          johndavidhock.com
> > <http://johndavidhock.com>
> >          ServerAlias                           www.johndavidhock.com
> > <http://www.johndavidhock.com>
> >          ProxyPreserveHost              on
> >          ProxyPass                            / http://192.168.1.104
> >          ProxyPass Reverse             / http://192.168.1.104
> > </VirtualHost>
> >
> > <VirtualHost *:80>
> >          ServerName                          johndavidhock.net
> > <http://johndavidhock.net>
> >          ServerAlias                           www.johndavidhock.net
> > <http://www.johndavidhock.net>
> >          ProxyPreserveHost              on
> >          ProxyPass                            / http://192.168.1.103
> >          ProxyPass Reverse             / http://192.168.1.103
> > </VirtualHost>
> >
> >
> > The reverse proxy is working in that I am able to access both websites
> > when I am at a mall, for example, and using their wifi.  The issue that
> > I am having is that the css files are not being picked up. In google
> > developer tools I am getting a 502 error for the css files.
> > Please not that I am not very technically savvy about Apache and have
> > learned most of what I know from watching youtube videos.  Also, these
> > servers are raspberry pi 3+ minicomputers.  I have asked for help on the
> > raspberry pi forums but they directed me to here.
> >
> > Is this something you can assist with?
> >
> >
> > Thanks very much,
> >
> >
> > Dave Hock
> >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message