httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Hock <daveh...@johndavidhock.net>
Subject [users@httpd] css files not loading
Date Mon, 10 Jun 2019 02:15:31 GMT
Hello,
      I am hoping to get some help with an issue concerning a reverse proxy
setup and static files.

I have two domains that I purchased from Google Domains, johndavidhock.net
and johndavidhock.com and have created very simple websites for both of the
domains which consist of a single html file and a css file, index.html and
main.css respectively.

My home network is setup as follows:
Server location: 192.168.1.103 - hosts the www.johndavidhock.net site
Server location: 192.168.1.104 - host the www.johndavidhock.com site


I also have a server at 192.168.1.105 which acts as a reverse proxy server
and has the following files in the /etc/apache2/sites-available folder:
Reverse Proxy Server location: 192.168.1.105

johndavidhock.com.conf
johndavidhock.net.conf

The contents are as follows:

<VirtualHost *:80>
         ServerName                          johndavidhock.com
         ServerAlias                           www.johndavidhock.com
         ProxyPreserveHost              on
         ProxyPass                            / http://192.168.1.104
         ProxyPass Reverse             / http://192.168.1.104
</VirtualHost>

<VirtualHost *:80>
         ServerName                          johndavidhock.net
         ServerAlias                           www.johndavidhock.net
         ProxyPreserveHost              on
         ProxyPass                            / http://192.168.1.103
         ProxyPass Reverse             / http://192.168.1.103
</VirtualHost>


The reverse proxy is working in that I am able to access both websites when
I am at a mall, for example, and using their wifi.  The issue that I am
having is that the css files are not being picked up. In google developer
tools I am getting a 502 error for the css files.
Please not that I am not very technically savvy about Apache and have
learned most of what I know from watching youtube videos.  Also, these
servers are raspberry pi 3+ minicomputers.  I have asked for help on the
raspberry pi forums but they directed me to here.

Is this something you can assist with?


Thanks very much,


Dave Hock

Mime
View raw message