httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Gardiner <li...@glidos.net>
Subject [users@httpd] https requests working, but http mostly not
Date Sun, 24 Nov 2019 15:55:38 GMT
I'm using Apache 2.4.33 on opensuse Leap 15.1. I'm a long time user of 
apache, but I cannot claim to be particularly knowledgeable. I mostly 
use the opensuse defaults with my configuration changes kept in a git repo.

Something like a year ago, I set up mod_rewrite to automatically 
redirect all http requests to https. That's been working fine and still 
is. There are a few cases where I still need to permit http access, so I 
have a few extra rules to override the main one for these special cases. 
I added a new one recently and found it isn't working. The rule is 
working and the http requests are getting through without being 
redirected, but in many cases only headers are being sent back with no 
data. curl -v -f is showing no data and then failing with error 18 
(which I believe means the amount of data sent doesn't match what was 
reported in the header - and it seems to be no data sent at all causing 
this). Whether this failure occurs seems to depend on where I make the 
request from and how big the file is. Requests from the server itself 
(but via the external interface) mostly work. From other machines on the 
network, the bigger the file the more likely is failure. This suggests 
timing may be involved to me, but I have no other evidence that that is 
the case.

I see no errors in the error logs. All the accesses show up in the 
access logs (failure or not). I've tried changing places in the config 
where log level is defined to "debug", but still nothing is reported.

I tried removing my mod_rewrite rules completely and then I see problems 
throughout the sites I serve when using http rather than https. I have 
horde/imp webmail: strangely the php files are still interpreted and the 
result served, but css files and images don't appear.

I tried removing mod_ssl and mod_reqtimeout, but that seemed to make no 
difference.

I just wondered if anyone could suggest a possible cause, or a way to 
discover more information on the problem. Any help would be much 
appreciated.

Cheers,
	Paul.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message