ibatis-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Marzo (JIRA)" <ibatis-...@incubator.apache.org>
Subject [jira] Commented: (IBATISNET-108) Resources.GetEmbeddedResourceAsXmlDocument( )
Date Sat, 27 Aug 2005 17:01:05 GMT
    [ http://issues.apache.org/jira/browse/IBATISNET-108?page=comments#action_12320275 ] 

David Marzo commented on IBATISNET-108:
---------------------------------------

I create this new Issue because http://issues.apache.org/jira/browse/IBATISNET-103 is closed
and I dont know if Gilles or other responsable be aware of the comment publish in a closed
issue.

 I update the IBatisNet.DataMapper.Test.bin.debug.SqlMap_MSSQL_SqlClient.config

Original:
<providers resource="providers.config"/>
You guest:
<providers embedded="bin.Debug.providers.config, IBatisNet.DataMapper.Test"/>

And the test IBatisNet.DataMapper.Test.NUnit.SqlMapTests.ConfigureTest.TestConfigureViaStream()
run ok, but I think providers must be configured in this way:

<providers embedded="IBatisNet.DataMapper.Test.bin.Debug.providers.config, IBatisNet.DataMapper.Test"/>

following the same syntax of System.Assembly.GetManifestResourceStream( )
<providers embedded="namespaceOfResource.filename.extension,AssemblyName">

I think you miss something if you happend at the begining of the namespace the name of the
assembly,

what happend if the name of assembly no fit with the base namespace).

For Example:
AssemblyName: MapperTest
Resource: IBatisNet.DataMapper.Test.bin.Debug.providers.config

I belibe is best to follow the sintax that use System.Assembly.GetManifestResourceStream(
) in emmbedded attribute
No always the Assembly names fit the base namespace or at least is not a mandatory of .NET.
   
      

> Resources.GetEmbeddedResourceAsXmlDocument( )
> ---------------------------------------------
>
>          Key: IBATISNET-108
>          URL: http://issues.apache.org/jira/browse/IBATISNET-108
>      Project: iBatis for .NET
>         Type: Improvement
>     Reporter: David Marzo
>     Assignee: Gilles Bayon
>     Priority: Trivial
>      Fix For: DataMapper 1.3

>
> David Marzo posted the following message to the user-cs list. I've verified they are
present in the most recent revision in SVN:
> I have two small "bugs":
> cs\mapper\IBatisNet.Common\Utilities\Resources.cs 
>   ln 291 
>    Original: 
>    throw new ConfigurationException(string.Format("Unable to load 
>             XmlDocument via stream. Cause : {1}", e.Message ) ,e);
>    Correct:
>    throw new ConfigurationException(string.Format("Unable to load 
>             XmlDocument via stream. Cause : {0}", e.Message),e);
>   Similar error in Lines: 313,336,446
>  Ln 413
>  Original:
> 	Stream stream = 
> 	
> assembly.GetManifestResourceStream(fileInfo.ResourceFileName);
> Correct:
> 	Stream stream =
> assembly.GetManifestResourceStream(fileInfo.FileName);

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message