ibatis-user-cs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Douglas Smith" <douglas.sm...@aciwebs.com>
Subject iBatis Newbie: problem with providers.config
Date Mon, 17 Jul 2006 23:54:53 GMT
Hello I need some help.

 

I have been able to test and debug my test classes using NUnit, but I
have not been able to get past this problem (error message from NUnit
GUI):

 

 

ManageData.aci.matweb.data.test_Forecaster.GetData :
IBatisNet.Common.Exceptions.ConfigurationException : 

- The error occurred while load DataBase Provider.

- The error occurred in <provider name="sqlServer1.1"
xmlns="http://ibatis.apache.org/dataMapper" />.  

- Check the sqlServer1.1.

  ----> IBatisNet.Common.Exceptions.ConfigurationException : Error while
configuring the Provider named "sqlServer1.1". Cause : The provider is
not in 'providers.config'.

 

 

The provider *is* in providers.config, and the system *is* finding the
file; If I rename providers.config, I get a different file not found
error.

 

Here is my SQLMap.config file:

 

<?xml version="1.0" encoding="utf-8"?>

<sqlMapConfig xmlns="http://ibatis.apache.org/dataMapper" >

 

      <settings>

            <setting useStatementNamespaces="false"/>

            <setting cacheModelsEnabled="false"/>

      </settings>

      

      <database>  

            <provider name="sqlServer1.1" />

            <dataSource name="Forecasters"
connectionString="Server=#####;Database=#####;User
ID=####;Password=####;Trusted_Connection=False"/>

      </database>

 

      <sqlMaps>

            <sqlMap resource="../XMLMaps/Forecaster.xml"/>

      </sqlMaps>

      

</sqlMapConfig>

 

 

I am using #### to hide security details while sending to the list.

 

I cut my providers.config file down to just that single provider, and
the "enabled" attribute is *true*

 

Renaming the provider has no effect.

 

Any help appreciated :-)

 

 


Mime
View raw message