ibatis-user-cs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Grabowski <rongrabow...@yahoo.com>
Subject Re: MySql Connection problem
Date Tue, 17 Oct 2006 04:16:20 GMT

Have you verified the connetion string works on a normal MySqlConnection (or whatever MySql's
IDbConnection is)?

 using (IDbConnection connection = new MySqlConnection("..."))
 {
  Console.Write(connection.ConnectionState);
 }


----- Original Message ----

From: Tony Elmore <telmore@insightbb.com>

To: user-cs@ibatis.apache.org

Sent: Monday, October 16, 2006 12:22:16 PM

Subject: MySql Connection problem



                 <!--   /* Style Definitions */  p.MsoNormal, li.MsoNormal, div.MsoNormal
	{ margin:0in; margin-bottom:.0001pt;  font-size:12.0pt; font-family:"Times New Roman";  }
a:link, span.MsoHyperlink 	{color:blue; text-decoration:underline; } a:visited, span.MsoHyperlinkFollowed
	{color:purple; text-decoration:underline; } p.MsoPlainText, li.MsoPlainText, div.MsoPlainText
	{margin:0in; margin-bottom:.0001pt;  font-size:10.0pt; font-family:"Courier New"; } span.Style1
	{  color:fuchsia; font-weight:bold;  font-style:italic; text-decoration:underline; } span.EmailStyle19
	{  color:black;}  _filtered { margin:1.0in 1.25in 1.0in 1.25in;   } div.Section1 	{} -->
   p.MsoNormal 	{margin-left:18.75pt;}        Hello…

     

   I’ve been working with SQL Server and I’ve been able to execute just fine.  I am now
wanting to connect to a MySql DB.  

     

   So I installed the MySql Connector 1.0.7 and enabled the provider in the provider.config
and changed the specified provider in the SqlMap.config file (as well as my connection string
values in properties.config).

     

   However, when I attempt to perform a select statement, I receive the following error:

     

   ‘Unable to connect to any of the specified MySql hosts.  No such host is known’.

     

   The only oddity in the installation is that I’ve used a different port than the default.
 I’ve tried localhost:port and port=xxxx in the connection string.

     

   Any assistance would be appreciated.

     

   Regards,

   Tony

     

     

   

   








Mime
View raw message