ibatis-user-cs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arjen Smits" <ar...@ProPlanet.nl>
Subject RE: Problem with multiple iterate tags "list[].list"
Date Mon, 16 Apr 2007 12:13:04 GMT
I have run into a similar situation. Eventually we generated that part
of the SQL manually. 

Would be great if a solution can be found for this problem.

 


ProPlanet BV
Rijnstraat 495F
5215 EJ  's-Hertogenbosch
The Netherlands
Tel  +31 (0)73 513 0637
Fax +31 (0)73 631 2114
www.proplanet.eu  

Disclaimer

This e-mail and any attachment(s) sent with it are intended exclusively for
the addressee(s), and may not be used by, opened by, passed on to, or made
available for use to, any person other than the addressee(s). ProPlanet rules
out any and all liabilities resulting from any electronic transmission.

________________________________


Van: MANSUY Stephane (EURIWARE) [mailto:stephane.mansuy@euriware.fr] 
Verzonden: vrijdag 13 april 2007 11:11
Aan: user-cs@ibatis.apache.org
Onderwerp: Problem with multiple iterate tags "list[].list"

 

This map doesn't work with Ibatis for .NET, but she works fine with
Ibatis for JAVA
 
<iterate property="list">
  <iterate property="list[].list">
    #list[].list[].property#
  </iterate>
</iterate>

 

The error code is < Error getting ordinal value from .net object >

 

In the method OnDoStartFragment(), the propertyNameValue = < list[].list
> so the call to ObjectProbe.GetMemberValue fail

Mime
View raw message