ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yakov Zhdanov <yzhda...@apache.org>
Subject Re: Loading vs. Preloading
Date Mon, 02 Mar 2015 15:48:17 GMT
Sorry, correct link is - https://issues.apache.org/jira/browse/IGNITE-383

--Yakov

2015-03-02 18:47 GMT+03:00 Yakov Zhdanov <yzhdanov@apache.org>:

> Ticket filed - https://issues.apache.org/jira/browse/IGNITE-384
>
> --Yakov
>
> 2015-03-01 17:53 GMT+03:00 Vladimir Ozerov <vozerov@gridgain.com>:
>
>> +1
>>
>> Another problem is that "preload" meaning is not obvious. It sound like
>> "initial load", what does not reflect it's real purpose correctly.
>> One more idea is "repartition" what maps to "PARTITIONED" cache mode
>> nicely.
>>
>> On Sun, Mar 1, 2015 at 1:32 PM, Dmitriy Setrakyan <dsetrakyan@apache.org>
>> wrote:
>>
>> > Igniters,
>> >
>> > We have a concept of DataLoader which is responsible for loading large
>> > amounts of data into caches. We also have a concept of "preloading"
>> which
>> > is responsible for the data rebalancing which happens in the background.
>> >
>> > I think the naming for data-loading and preloading is too close and gets
>> > confusing. How about we renaming preloading to rebalancing? This would
>> > rename CachePreloadMode to CacheRebalanceMode. A bunch of preloading
>> > configuration properties will have to be renamed too (configuration
>> > properties are documented here:
>> > http://apacheignite.readme.io/v1.0/docs/rebalancing).
>> >
>> > Again, I am trying to finalize all API changes before resubmitting RC1
>> for
>> > a vote.
>> >
>> > Thoughts?
>> >
>> > D.
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message