ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 姜 为 <ydswcy...@gmail.com>
Subject Re: About Ignite-Spring with GridService issue.
Date Mon, 16 Nov 2015 04:03:24 GMT
I found hot to fix this, add @SpringResource to the field will work fine.

> 在 2015年11月16日,上午9:40,姜 为 <ydswcy513@gmail.com> 写道:
> 
> Hi:
> 	Here is example: https://github.com/wmz7year/ignite-test <https://github.com/wmz7year/ignite-test>
> 	
> 	I think the IgniteUtils.wrapThreadLoader load the class is not the spring proxy class.
> 
>     Does I’m right?
> 
>> 在 2015年11月14日,下午10:58,姜 为 <ydswcy513@gmail.com <mailto:ydswcy513@gmail.com>>
写道:
>> 
>> Hello,
>> 
>> 	I’m using Ignite-Spring testing GridService rpc.
>> 
>> 	Like this example https://github.com/apache/ignite/blob/master/examples/src/main/java/org/apache/ignite/examples/servicegrid/ServicesExample.java
<https://github.com/apache/ignite/blob/master/examples/src/main/java/org/apache/ignite/examples/servicegrid/ServicesExample.java>
>> 
>> 	I made change for SimpleMapServiceImpl use @Autowired to other service.
>> 	
>> 	Ignite start using same SpringApplicationContext:
>> 		IgniteSpring.start(config, context);
>> 	
>> 	and @Autowired is success .
>> 
>> 	But when Ignite.compute call  IgniteCallable service.
>> 	The @Autowired service will be null.
>> 
>> 	Is this I configured problem or Ignite issue?
>> 
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message