ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vasilisa Sidorova (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-3043) NPE during restart remote node by ignitevisorcmd
Date Thu, 21 Apr 2016 15:28:25 GMT
Vasilisa  Sidorova created IGNITE-3043:
------------------------------------------

             Summary: NPE during restart remote node by ignitevisorcmd
                 Key: IGNITE-3043
                 URL: https://issues.apache.org/jira/browse/IGNITE-3043
             Project: Ignite
          Issue Type: Bug
          Components: visor
    Affects Versions: 1.5.0.final
         Environment: Ubuntu 14.04
            Reporter: Vasilisa  Sidorova


---------------------------------------------
DESCRIPTION
---------------------------------------------
There is NPE during restart remote nodes by ignitevisorcmd command "start" but nodes are restarted
---------------------------------------------
STEPS FOR REPRODUCE
---------------------------------------------
# Run node on the localhost
# Run ignitevisorcmd on the localhost
# Open connection to the running node
# Run nodes on the another host by the command 
{noformat}
start -h=another_host_ip -u=username -pw=username_password -t=30000 -n=3 -g=path_to_ignite_installation_folder
-c=path_to_configuration_file
{noformat}
# Verify nodes are started OK
# Run command 
{noformat}
start -r -h=another_host_ip -u=username -pw=username_password -t=30000 -n=2 -g=path_to_ignite_installation_folder
-c=path_to_configuration_file
{noformat}
---------------------------------------------
ACTUAL RESULT
---------------------------------------------
# There is NPE during restart remote nodes but nodes are restarted. Look at the attached log
file
# All 3 remote nodes are stopped and 2 nodes are started again
---------------------------------------------
EXPECTED RESULT
---------------------------------------------
# There aren't any errors during "start" command execution
# Only 2 remote nodes are restarted and one of them stay running
---------------------------------------------
ADDITIONAL INFO
---------------------------------------------
# Sometimes the same NPE appears during starting remote nodes but this is unstable reproducible



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message