ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Veselovsky (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IGNITE-5131) Hadoop: update asm library to a version that can parse 1.8 bytecode
Date Tue, 02 May 2017 12:43:04 GMT
Ivan Veselovsky created IGNITE-5131:
---------------------------------------

             Summary: Hadoop: update asm library to a version that can parse 1.8 bytecode
                 Key: IGNITE-5131
                 URL: https://issues.apache.org/jira/browse/IGNITE-5131
             Project: Ignite
          Issue Type: Bug
          Components: hadoop
            Reporter: Ivan Veselovsky
            Assignee: Ivan Veselovsky
            Priority: Minor


This question indicates, that asm bytecode parser 4.2 cannot parse 1.8 bytecode:
http://stackoverflow.com/questions/34318028/apache-ignite-failed-to-load-job-class-class-org-apache-ignite-internal-proces

         <dependency>
             <groupId>org.ow2.asm</groupId>
             <artifactId>asm-all</artifactId>
             <version>4.2</version>
         </dependency>

Consider to update asm lib to newer version that understands 1.8 bytecode version, (likely
5.2 ? http://search.maven.org/#search%7Cgav%7C1%7Cg%3A%22org.ow2.asm%22%20AND%20a%3A%22asm-all%22
)





--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message