ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitry Melnichuk <dmitry.melnic...@nobitlost.com>
Subject Re: Python thin client
Date Tue, 11 Sep 2018 07:33:49 GMT
Igor,

I literally followed the steps you describe, but unfortunately could not 
reproduce the error.

The only clue I got is that your site-packages already have the newer 
version of attrs (18.2.0 against 18.1.0 as of pyignite requirements). 
But this should not be an issue, since pytest-runner in this command 
creates its own test environment, independent of the one it runs into. 
It worked for me when I installed `attrs==18.2.0` locally and run tests 
− everything went smooth.

You can try uninstalling or downgrading your local attrs with

```
$ pip3 uninstall attrs
```

but I don't think it will actually help. Maybe it will raise another 
error, so we could dig deeper into the problem.

Alternatively, you can give me more details to recreate it (OS, Python 
and pip versions). I'm not ruling out a bug in setuptools.

On 9/11/18 2:13 AM, Igor Sapego wrote:
> Guys, I've cloned your repository, run pip3 install -e .
> then run pip3 install -r requirements/* over all the requirements,
> and finally run python ./setup.py pytest, but get the following output:
> 
> running pytest
> Searching for attrs==18.1.0
> Best match: attrs 18.1.0
> 
> Using /home/isapego/.local/lib/python3.6/site-packages
> running egg_info
> writing pyignite.egg-info/PKG-INFO
> writing dependency_links to pyignite.egg-info/dependency_links.txt
> writing requirements to pyignite.egg-info/requires.txt
> writing top-level names to pyignite.egg-info/top_level.txt
> reading manifest file 'pyignite.egg-info/SOURCES.txt'
> writing manifest file 'pyignite.egg-info/SOURCES.txt'
> running build_ext
> Traceback (most recent call last):
>    File "./setup.py", line 98, in <module>
>      'Operating System :: OS Independent',
>    File
> "/home/isapego/.local/lib/python3.6/site-packages/setuptools/__init__.py",
> line 140, in setup
>      return distutils.core.setup(**attrs)
>    File "/usr/lib/python3.6/distutils/core.py", line 148, in setup
>      dist.run_commands()
>    File "/usr/lib/python3.6/distutils/dist.py", line 955, in run_commands
>      self.run_command(cmd)
>    File "/usr/lib/python3.6/distutils/dist.py", line 974, in run_command
>      cmd_obj.run()
>    File "/home/isapego/.local/lib/python3.6/site-packages/ptr.py", line 175,
> in run
>      with self.project_on_sys_path():
>    File "/usr/lib/python3.6/contextlib.py", line 81, in __enter__
>      return next(self.gen)
>    File
> "/home/isapego/.local/lib/python3.6/site-packages/setuptools/command/test.py",
> line 166, in project_on_sys_path
>      require('%s==%s' % (ei_cmd.egg_name, ei_cmd.egg_version))
>    File
> "/home/isapego/.local/lib/python3.6/site-packages/pkg_resources/__init__.py",
> line 895, in require
>      needed = self.resolve(parse_requirements(requirements))
>    File
> "/home/isapego/.local/lib/python3.6/site-packages/pkg_resources/__init__.py",
> line 786, in resolve
>      raise VersionConflict(dist, req).with_context(dependent_req)
> pkg_resources.ContextualVersionConflict: (attrs 18.2.0
> (/home/isapego/.local/lib/python3.6/site-packages),
> Requirement.parse('attrs==18.1.0'), {'pyignite'})
> 
> What am I doing wrong?
> 
> Best Regards,
> Igor
> 

Mime
View raw message