ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitry Melnichuk <dmitry.melnic...@nobitlost.com>
Subject Re: Python thin client
Date Wed, 12 Sep 2018 21:52:02 GMT
Igor,

Yes, it's my bad, sorry. Just merged the Ignite master with my branch.

On 9/12/18 8:47 PM, Igor Sapego wrote:
> Pavel,
> Yes, I did. I tried completely clean environment, followed the same
> steps and got the same error. Then I removed attr, and out of sudden
> everything started working.
> 
> Dmitry,
> Thanks, now it's more clear:
> Handshake error: Unsupported version. Server expects binary protocol
> version 1.1.0. Client provides 1.2.0.
> 
> Why do you use version 1.2.0, but have outdated server code? I
> propose you to merge with or rebase onto Ignite's master branch.
> 
> Best Regards,
> Igor
> 
> 
> On Tue, Sep 11, 2018 at 11:21 PM Dmitry Melnichuk <
> dmitry.melnichuk@nobitlost.com> wrote:
> 
>> Igor,
>>
>> I have just commited an improvment to the HandshakeError message
>> generation algorithm. I hope it is now easier to understand what expects
>> what in case of binary protocol version mismatch.
>>
>> Thank you for pointing this out.
>>
>> On 9/12/18 2:13 AM, Igor Sapego wrote:
>>> I managed to start tests, and now I'm getting the following message:
>>>
>>> pyignite.exceptions.HandshakeError: Handshake error: Unsupported
>>> version. Expected protocol version: 1.1.0.
>>>
>>> It would be useful to print "Unexpected version" itself, because I can
>>> not understand what is the issue.
>>>
>>> Best Regards,
>>> Igor
>>
> 


Mime
View raw message