ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitry Melnichuk <dmitry.melnic...@nobitlost.com>
Subject Re: Python thin client
Date Mon, 03 Sep 2018 07:07:25 GMT
Hello, Nikolay!

Thank you for your interest in Python thin client.

The traceback suggests that you using Python 2.7. Unfortunately, my 
client supports only Python versions 3.4 and later.

Since you are using the latest Ubuntu OS, chances are you already have a 
recent Python 3 installed. Try `pip3`.

On 9/3/18 4:25 PM, Nikolay Izhikov wrote:
> Hello, Dmitry.
> 
> I tried to build your lib locally and it failed.
> Error message and pip version are below.
> 
> Seems, we have to fix developer instructions.
> Do we need specific version of pip or something?
> I tried to use default versions.
> I using Ubuntu Linux.
> 
> dragon:~/src/ignite/modules/platforms/python:[IGNITE-7782]$ pip install -v -e .
> Obtaining file:///home/dragon/src/ignite/modules/platforms/python
>    Running setup.py (path:/home/dragon/src/ignite/modules/platforms/python/setup.py)
egg_info for package from file:///home/dragon/src/ignite/modules/platforms/python
>      Running command python setup.py egg_info
>      Traceback (most recent call last):
>        File "<string>", line 1, in <module>
>        File "/home/dragon/src/ignite/modules/platforms/python/setup.py", line 20
>          def is_a_requirement(line: str) -> bool:
>                                   ^
>      SyntaxError: invalid syntax
> Cleaning up...
> Command "python setup.py egg_info" failed with error code 1 in /home/dragon/src/ignite/modules/platforms/python/
> Exception information:
> Traceback (most recent call last):
>    File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
>      status = self.run(options, args)
>    File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 353, in run
>      wb.build(autobuilding=True)
>    File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
>      self.requirement_set.prepare_files(self.finder)
>    File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
>      ignore_dependencies=self.ignore_dependencies))
>    File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 518, in _prepare_file
>      abstract_dist.prep_for_dist()
>    File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 129, in prep_for_dist
>      self.req_to_install.run_egg_info()
>    File "/usr/lib/python2.7/dist-packages/pip/req/req_install.py", line 439, in run_egg_info
>      command_desc='python setup.py egg_info')
>    File "/usr/lib/python2.7/dist-packages/pip/utils/__init__.py", line 725, in call_subprocess
>      % (command_desc, proc.returncode, cwd))
> InstallationError: Command "python setup.py egg_info" failed with error code 1 in /home/dragon/src/ignite/modules/platforms/python/
> dragon:~/src/ignite/modules/platforms/python:[IGNITE-7782]$ apt-cache policy python-pip
> python-pip:
>    Установлен: 9.0.1-2.3~ubuntu1
>    Кандидат:   9.0.1-2.3~ubuntu1
>    Таблица версий:
>   *** 9.0.1-2.3~ubuntu1 500
>          500 http://ru.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
>          500 http://ru.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages
>          100 /var/lib/dpkg/status
>       9.0.1-2 500
>          500 http://ru.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
>          500 http://ru.archive.ubuntu.com/ubuntu bionic/universe i386 Packages
> dragon:~/src/ignite/modules/platforms/python:[IGNITE-7782]$ uname -a
> Linux newDragon 4.15.0-33-generic #36-Ubuntu SMP Wed Aug 15 16:00:05 UTC 2018 x86_64
x86_64 x86_64 GNU/Linux
> 

Mime
View raw message