ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Artem Budnikov <a.budnikov.ign...@gmail.com>
Subject Re: apache-ignite_2.8.0-1_all.deb package has older version of openjdk as dependency
Date Thu, 27 Aug 2020 08:55:59 GMT
Looks like this issue wasn't fixed in 2.8.1. The Ignite deb package v. 
2.8.1 can't be installed on debian 10:

> $ sudo apt-get install apache-ignite
> ...
> The following packages have unmet dependencies:
>  apache-ignite : Depends: openjdk-8-jdk but it is not installable or
>                         oracle-java8-installer but it is not installable
> E: Unable to correct problems, you have held broken packages.

Is anyone working on this? I was going to update the Ignite 2.9 
installation instruction for Debian, but if the issue is staying with 
us, I guess I shouldn't bother.

-Artem

On 27.05.2020 11:55, Ilya Kasnacheev wrote:
> Hello!
>
> You can build debian package from apache-ignite source deliverable. 
> There you can fix the dependency.
>
> Regards,
> -- 
> Ilya Kasnacheev
>
>
> ср, 27 мая 2020 г. в 11:51, rakshita04 <rakshita.chaudhary@siemens.com 
> <mailto:rakshita.chaudhary@siemens.com>>:
>
>     Can we have the newer debian package for apache ignite with newer
>     version of
>     openjdk as dependencies?
>
>
>
>     --
>     Sent from: http://apache-ignite-users.70518.x6.nabble.com/
>     <http://apache-ignite-users.70518.x6.nabble.com/>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message