ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Denis Magda <dma...@apache.org>
Subject Re: Can't build new documentation with Jekyll
Date Tue, 03 Nov 2020 16:23:53 GMT
Hi Pavel,

Welcome to the club :) Even though Jekyll's website boasts about a
single-command-installation experience, true life is quite opposite.
Most of the troubles are caused by Ruby. For instance, while everything
worked like a charm on my colleague's laptop, I had to clean Ruby and
Jekyll installation traits multiple times experimenting with different
installation options.

Anyway, let's try to make it running on your end:

   - I've just merged the troubleshooting section
   The suggestions are for MacOS but it might be applicable for your OS as
   - If the above is of a little help, then clean Ruby and Jekyll
   installation and use the following command for re-install the toolchain: gem
   install jekyll-asciidoc pygments.rb thread_safe slim

It's a miracle for me why the setup fails in Docker. Probably, we just need
to pass in some special commands to Docker while it will be installing
Jekyll and Ruby.


On Mon, Nov 2, 2020 at 11:30 PM Pavel Tupitsyn <ptupitsyn@apache.org> wrote:

> Igniters,
> I tried to build the docs today using the instructions from README.adoc [1]
> Bare Jekyll:
> /usr/lib/ruby/vendor_ruby/rouge.rb:55:in `block in <top (required)>':
> asciidoctor: FAILED:
> /home/pavel/w/ignite/docs/_docs/SQL/JDBC/error-codes.adoc: Failed to load
> AsciiDoc document - uninitialized constant Rouge::Lexers
> Docker:
> Downloading listen-3.1.5 revealed dependencies not in the API or the
> lockfile
> (rb-fsevent (>= 0.9.4, ~> 0.9), ruby_dep (~> 1.2)).
> Either installing with `--full-index` or running `bundle update listen`
> should
> fix the problem.
> Any idea what may be wrong?
> [1] https://github.com/apache/ignite/blob/master/docs/README.adoc

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message