ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raymond Wilson <raymond_wil...@trimble.com>
Subject Re: Issue building Ignite 2.10 branch
Date Wed, 12 May 2021 01:29:51 GMT
Hi Vishwas,

I added the following to my global Maven settings.xml file in the .m2
folder:

<?xml version="1.0" encoding="UTF-8"?>
<settings xmlns="http://maven.apache.org/SETTINGS/1.0.0"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0
http://maven.apache.org/xsd/settings-1.0.0.xsd">

<profiles>
   <profile>
     <id>myprofile</id>
     <repositories>
       <repository>
         <id>my-repo2</id>
         <name>your custom repo</name>
         <url>https://repository.ow2.org/nexus/content/repositories/public/
</url>
       </repository>
     </repositories>
   </profile>
 </profiles>
</settings>

I get the same result on running the "mvn clean install
-Pall-java,all-scala,licenses -DskipTests" command line:

[ERROR] Failed to execute goal on project ignite-jta: Could not resolve
dependencies for project org.apache.ignite:ignite-jta:jar:2.10.0: Failed to
collect dependencies at org.ow2.jotm:jotm-core:jar:2.2.3 ->
org.ow2.carol:carol:jar:3.0.8 ->
org.jacorb:jacorb:jar:2.2.3-jonas-patch-20071018: Failed to read artifact
descriptor for org.jacorb:jacorb:jar:2.2.3-jonas-patch-20071018: Could not
transfer artifact org.jacorb:jacorb:pom:2.2.3-jonas-patch-20071018 from/to
maven-default-http-blocker (http://0.0.0.0/): transfer failed for
http://0.0.0.0/org/jacorb/jacorb/2.2.3-jonas-patch-20071018/jacorb-2.2.3-jonas-patch-20071018.pom:
Connect to 0.0.0.0:80 [/0.0.0.0] failed: Connection refused: connect ->
[Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the
command
[ERROR]   mvn <args> -rf :ignite-jta

Raymond.

On Wed, May 12, 2021 at 12:50 PM Vishwas Bm <bmvishwas@gmail.com> wrote:

> Hi Raymond,
>
> This is an issue related to repository configuration in settings.xml.
>
> You can find more information in below thread
>
> http://apache-ignite-developers.2346864.n4.nabble.com/Building-Ignite-with-Adopt-OpenJDK-11-td52389.html#a52391
>
>
>
> Regards,
> Vishwas
>
> On Wed, 12 May, 2021, 05:17 Raymond Wilson, <raymond_wilson@trimble.com>
> wrote:
>
> > Hi,
> >
> > I have made a small modification to the ignite-kubernetes module to allow
> > specification of a port for the IP finder.
> >
> > To build Ignite, I am using this comment from DEVNOTES.TXT:
> >
> > mvn clean install -am -Pall-java,all-scala,licenses -DskipTests
> >
> > This ultimately fails with the following error:
> >
> > [ERROR] Failed to execute goal on project ignite-jta: Could not resolve
> > dependencies for project org.apache.ignite:ignite-jta:jar:2.10.0: Failed
> to
> > collect dependencies at org.ow2.jotm:jotm-core:jar:2.2.3 ->
> > org.ow2.carol:carol:jar:3.0.8 ->
> > org.jacorb:jacorb:jar:2.2.3-jonas-patch-20071018: Failed to read artifact
> > descriptor for org.jacorb:jacorb:jar:2.2.3-jonas-patch-20071018: Could
> not
> > transfer artifact org.jacorb:jacorb:pom:2.2.3-jonas-patch-20071018
> from/to
> > maven-default-http-blocker (http://0.0.0.0/): transfer failed for
> >
> >
> http://0.0.0.0/org/jacorb/jacorb/2.2.3-jonas-patch-20071018/jacorb-2.2.3-jonas-patch-20071018.pom
> > :
> > Connect to 0.0.0.0:80 [/0.0.0.0] failed: Connection refused: connect ->
> > [Help 1]
> > [ERROR]
> > [ERROR] To see the full stack trace of the errors, re-run Maven with the
> -e
> > switch.
> > [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> > [ERROR]
> > [ERROR] For more information about the errors and possible solutions,
> > please read the following articles:
> > [ERROR] [Help 1]
> >
> >
> http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
> > [ERROR]
> > [ERROR] After correcting the problems, you can resume the build with the
> > command
> > [ERROR]   mvn <args> -rf :ignite-jta
> >
> > I found some release notes that indicated the Maven (as of 3.8.1) is no
> > longer supporting HTTP addresses for dependencies. I downgraded to Maven
> > 3.8.0 with no change to the result.
> >
> > Is there an easy work around for this?
> >
> > Thanks,
> > Raymond.
> >
> >
> > --
> > <http://www.trimble.com/>
> > Raymond Wilson
> > Trimble Distinguished Engineer, Civil Construction Software (CCS)
> > 11 Birmingham Drive | Christchurch, New Zealand
> > raymond_wilson@trimble.com
> >
> > <
> >
> https://worksos.trimble.com/?utm_source=Trimble&utm_medium=emailsign&utm_campaign=Launch
> > >
> >
>


-- 
<http://www.trimble.com/>
Raymond Wilson
Trimble Distinguished Engineer, Civil Construction Software (CCS)
11 Birmingham Drive | Christchurch, New Zealand
raymond_wilson@trimble.com

<https://worksos.trimble.com/?utm_source=Trimble&utm_medium=emailsign&utm_campaign=Launch>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message