incubator-adffaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Winer" <awi...@gmail.com>
Subject Re: Re: Re: Re: [Proposal] (re)naming issue
Date Wed, 26 Jul 2006 22:46:26 GMT
For classes that are in adf-faces-impl, the name doesn't
deeply matter - just map AdfFaces to Trinidad.  The public
class is Agent;  AdfFacesAgent is a private impl.
(AdfRenderingContext is going to be made public at
some point, so I do care about that name).

-- Adam

On 7/26/06, Matthias Wessendorf <matzew@apache.org> wrote:
> Agent is for user-agent. but more finer than the JSF spec is ;)
>
> On 7/26/06, Cosma Colanicchia <cosmacol@gmail.com> wrote:
> > Don't know what that agent do.. so I presume you're right :)
> >
> >
> > 2006/7/26, Matthias Wessendorf <matzew@apache.org>:
> > > Sure,
> > >
> > > but that Agent stuff might be usfull outside.
> > > TrinidadComponentHandler is only useful for Trinidad itself
> > >
> > > that's why I asked.
> > >
> > >
> > >
> > > On 7/26/06, Cosma Colanicchia <cosmacol@gmail.com> wrote:
> > > > Why do you say that it sound strange?
> > > >
> > > > ... but how many AdfFaces* classes are there? ;-)
> > > >
> > > >
> > > > 2006/7/26, Matthias Wessendorf <matzew@apache.org>:
> > > > > What about
> > > > >
> > > > > AdfFacesAgent ?
> > > > >
> > > > > TrinidadAgent sounds strange.
> > > > >
> > > > >
> > > > >
> > > > > On 7/26/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > > > > After all is done, I setup a wiki page for a better orientation.
> > > > > > this thread is just for being clear on names and getting feedback
from you guys.
> > > > > >
> > > > > > -Matt
> > > > > >
> > > > > > On 7/26/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > > > > > clazzes like
> > > > > > >
> > > > > > > AdfFacesVariableResolver => TrinidadVariableResolver
> > > > > > > AdfFacesPhaseListener => TrinidadPhaseListener
> > > > > > >
> > > > > > > -Matthias
> > > > > > >
> > > > > > > On 7/26/06, Matthias Wessendorf <matzew@apache.org>
wrote:
> > > > > > > > Yeah,
> > > > > > > >
> > > > > > > > why not :)
> > > > > > > > Thanks for your input Simon. I'll do the renaming
of these guys later
> > > > > > > > to get some more feedback.
> > > > > > > > -Matt
> > > > > > > >
> > > > > > > >
> > > > > > > > On 7/26/06, Simon_Lessard@dmr.ca <Simon_Lessard@dmr.ca>
wrote:
> > > > > > > > > That might be heresy, but I would use TrinidadLogger
and create a new task
> > > > > > > > > to convert logging to commons-logging and/or
log4j rather than a home made
> > > > > > > > > JDK 1.4 logger.
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > Regards,
> > > > > > > > >
> > > > > > > > > Simon Lessard
> > > > > > > > > Fujitsu Consulting
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > "Matthias Wessendorf" <matzew@apache.org>
> > > > > > > > > Sent by: mwessendorf@gmail.com
> > > > > > > > > 2006-07-26 16:19
> > > > > > > > > Please respond to adffaces-dev
> > > > > > > > >
> > > > > > > > >         To:     adffaces-dev@incubator.apache.org
> > > > > > > > >         cc:
> > > > > > > > >         Subject:        Re: Re: Re: [Proposal]
(re)naming issue
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > folks,
> > > > > > > > >
> > > > > > > > > more
> > > > > > > > > AdfFacesFilter => RequestFilter ?
> > > > > > > > >
> > > > > > > > > but what with:
> > > > > > > > > ADFLogger
> > > > > > > > > ADFLoggerRecord
> > > > > > > > >
> > > > > > > > > -Matthias
> > > > > > > > >
> > > > > > > > > On 7/24/06, Adam Winer <awiner@gmail.com>
wrote:
> > > > > > > > > > +1
> > > > > > > > > >
> > > > > > > > > > On 7/24/06, Matthias Wessendorf <matzew@apache.org>
wrote:
> > > > > > > > > > > What with
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > <faceletHandlerClass>org.apache.myfaces.adfinternal.facelets.AdfComponentHandler</faceletHandlerClass>
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > ?
> > > > > > > > > > >
> > > > > > > > > > > I am fine with TrinidadComponentHandler,
b/c this is *specific* to T.
> > > > > > > > > > >
> > > > > > > > > > > -Matt
> > > > > > > > > > >
> > > > > > > > > > > On 7/21/06, Matthias Wessendorf <matzew@apache.org>
wrote:
> > > > > > > > > > > > On 7/20/06, Adam Winer <awiner@gmail.com>
wrote:
> > > > > > > > > > > > > For class names, I'm thinking
that:
> > > > > > > > > > > > >   AdfFacesContext -> RequestContext,
or maybe LifecycleContext
> > > > > > > > > > > > >   AdfRenderingContext ->
RenderingContext
> > > > > > > > > > > > > (the latter is currently
a private-ish internal class, but I think
> > > > > > > > > > > > > we should make it public
at some point.)
> > > > > > > > > > > >
> > > > > > > > > > > > I like that RequestContext and
RenderingContext thing
> > > > > > > > > > > >
> > > > > > > > > > > > > I also wish we could keep
the "internal" part of the package;  I'd
> > > > > > > > > > > > > rather have:
> > > > > > > > > > > > >
> > > > > > > > > > > > > org.apache.myfacesinternal.trinidad
> > > > > > > > > > > > > org.apache.myfaces.trinidadinternal
> > > > > > > > > > > >
> > > > > > > > > > > > ok.
> > > > > > > > > > > >
> > > > > > > > > > > > Any other opinion ?
> > > > > > > > > > > >
> > > > > > > > > > > > > ... than:
> > > > > > > > > > > > >
> > > > > > > > > > > > > org.apache.myfaces.trinidad.internal
> > > > > > > > > > > > >
> > > > > > > > > > > > > Doing it "without the dot"
forces all the internal code
> > > > > > > > > > > > > into an entirely different
directory structure, which is
> > > > > > > > > > > > > handy for things like doc
+ inclusion rules - you don't
> > > > > > > > > > > > > have to specify exclusion
rules, just inclusion.
> > > > > > > > > > > > >
> > > > > > > > > > > > > -- Adam
> > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > > > On 7/20/06, Matthias Wessendorf
<matzew@apache.org> wrote:
> > > > > > > > > > > > > > > ADF-FACES-API
> > > > > > > > > > > > > > > package
> > > > > > > > > > > > > > > from
> > > > > > > > > > > > > > > org.apache.myfaces.adf.**
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > to
> > > > > > > > > > > > > > > org.apache.myfaces.trinidad.**
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > ADF-FACES-IMPL
> > > > > > > > > > > > > > > package
> > > > > > > > > > > > > > > from
> > > > > > > > > > > > > > > org.apache.myfaces.adfinternal.**
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > to
> > > > > > > > > > > > > > > org.apache.myfaces.trinidad.internal.**
> > > > > > > > > > > > > > > (note trinidad
DOT internal)
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Since nobody seams to
have a problem with the package
> > > > > > > > > suggestion, I think we
> > > > > > > > > > > > > > should move on on this
task, ok ?
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > o.a.m.trinidad is also
fine. Tobago does the same.
> > > > > > > > > > > > > > they use also the myfaces
specific namespace.
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > Only tomahawk doesn't
:)
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > org.apache.myfaces.custom
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > but that is from ooooooooold
days. Hard to change :)
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > > More interesting
are class names like AdfFacesContext.
> > > > > > > > > > > > > > > Naming them TrinidadContext
might not a good solution.
> > > > > > > > > > > > > > > Note: This class
is *not* extending FacesContext.
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > ExternalContext
might be a good name...
> > > > > > > > > > > > > > > but... as we all
know, this is already taken :)
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > Any ideas?
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > --
> > > > > > > > > > > > > > > Matthias Wessendorf
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > > > further stuff:
> > > > > > > > > > > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > > > > > > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > --
> > > > > > > > > > > > > > Matthias Wessendorf
> > > > > > > > > > > > > >
> > > > > > > > > > > > > > further stuff:
> > > > > > > > > > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > > > > > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > > > > > > > > > >
> > > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > >
> > > > > > > > > > > > --
> > > > > > > > > > > > Matthias Wessendorf
> > > > > > > > > > > >
> > > > > > > > > > > > further stuff:
> > > > > > > > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > > > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > >
> > > > > > > > > > > --
> > > > > > > > > > > Matthias Wessendorf
> > > > > > > > > > >
> > > > > > > > > > > further stuff:
> > > > > > > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > > > > > > >
> > > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > --
> > > > > > > > > Matthias Wessendorf
> > > > > > > > >
> > > > > > > > > further stuff:
> > > > > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > > > > >
> > > > > > > > >
> > > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > --
> > > > > > > > Matthias Wessendorf
> > > > > > > >
> > > > > > > > further stuff:
> > > > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Matthias Wessendorf
> > > > > > >
> > > > > > > further stuff:
> > > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > > >
> > > > > >
> > > > > >
> > > > > > --
> > > > > > Matthias Wessendorf
> > > > > >
> > > > > > further stuff:
> > > > > > blog: http://jroller.com/page/mwessendorf
> > > > > > mail: mwessendorf-at-gmail-dot-com
> > > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Matthias Wessendorf
> > > > >
> > > > > further stuff:
> > > > > blog: http://jroller.com/page/mwessendorf
> > > > > mail: mwessendorf-at-gmail-dot-com
> > > > >
> > > >
> > >
> > >
> > > --
> > > Matthias Wessendorf
> > >
> > > further stuff:
> > > blog: http://jroller.com/page/mwessendorf
> > > mail: mwessendorf-at-gmail-dot-com
> > >
> >
>
>
> --
> Matthias Wessendorf
>
> further stuff:
> blog: http://jroller.com/page/mwessendorf
> mail: mwessendorf-at-gmail-dot-com
>

Mime
View raw message