incubator-adffaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: Re: [Proposal] (re)naming issue
Date Mon, 24 Jul 2006 22:05:44 GMT
What with

          <faceletHandlerClass>org.apache.myfaces.adfinternal.facelets.AdfComponentHandler</faceletHandlerClass>


?

I am fine with TrinidadComponentHandler, b/c this is *specific* to T.

-Matt

On 7/21/06, Matthias Wessendorf <matzew@apache.org> wrote:
> On 7/20/06, Adam Winer <awiner@gmail.com> wrote:
> > For class names, I'm thinking that:
> >   AdfFacesContext -> RequestContext, or maybe LifecycleContext
> >   AdfRenderingContext -> RenderingContext
> > (the latter is currently a private-ish internal class, but I think
> > we should make it public at some point.)
>
> I like that RequestContext and RenderingContext thing
>
> > I also wish we could keep the "internal" part of the package;  I'd
> > rather have:
> >
> > org.apache.myfacesinternal.trinidad
> > org.apache.myfaces.trinidadinternal
>
> ok.
>
> Any other opinion ?
>
> > ... than:
> >
> > org.apache.myfaces.trinidad.internal
> >
> > Doing it "without the dot" forces all the internal code
> > into an entirely different directory structure, which is
> > handy for things like doc + inclusion rules - you don't
> > have to specify exclusion rules, just inclusion.
> >
> > -- Adam
> >
> >
> > On 7/20/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > > ADF-FACES-API
> > > > package
> > > > from
> > > > org.apache.myfaces.adf.**
> > > >
> > > > to
> > > > org.apache.myfaces.trinidad.**
> > > >
> > > > ADF-FACES-IMPL
> > > > package
> > > > from
> > > > org.apache.myfaces.adfinternal.**
> > > >
> > > > to
> > > > org.apache.myfaces.trinidad.internal.**
> > > > (note trinidad DOT internal)
> > >
> > > Since nobody seams to have a problem with the package suggestion, I think we
> > > should move on on this task, ok ?
> > >
> > > o.a.m.trinidad is also fine. Tobago does the same.
> > > they use also the myfaces specific namespace.
> > >
> > > Only tomahawk doesn't :)
> > >
> > > org.apache.myfaces.custom
> > >
> > > but that is from ooooooooold days. Hard to change :)
> > >
> > >
> > >
> > > > More interesting are class names like AdfFacesContext.
> > > > Naming them TrinidadContext might not a good solution.
> > > > Note: This class is *not* extending FacesContext.
> > > >
> > > > ExternalContext might be a good name...
> > > > but... as we all know, this is already taken :)
> > > >
> > > > Any ideas?
> > > >
> > > > --
> > > > Matthias Wessendorf
> > > >
> > > > further stuff:
> > > > blog: http://jroller.com/page/mwessendorf
> > > > mail: mwessendorf-at-gmail-dot-com
> > > >
> > >
> > >
> > > --
> > > Matthias Wessendorf
> > >
> > > further stuff:
> > > blog: http://jroller.com/page/mwessendorf
> > > mail: mwessendorf-at-gmail-dot-com
> > >
> >
>
>
> --
> Matthias Wessendorf
>
> further stuff:
> blog: http://jroller.com/page/mwessendorf
> mail: mwessendorf-at-gmail-dot-com
>


-- 
Matthias Wessendorf

further stuff:
blog: http://jroller.com/page/mwessendorf
mail: mwessendorf-at-gmail-dot-com

Mime
View raw message