incubator-adffaces-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simon Lessard" <simon.lessar...@gmail.com>
Subject Re: api cleanup for UIXCollection
Date Thu, 26 Oct 2006 01:00:54 GMT
+1 as well, when I first saw that method I thought about money.

On 10/25/06, Adam Winer <awiner@gmail.com> wrote:
>
> +1 for me - I've always found the word "currency" to be
> incredibly confusing.
>
> -- Adam
>
>
> On 10/24/06, Arjuna Wijeyekoon <arjuna@gmail.com> wrote:
> > Hi,
> > Currently UIXCollection has the following methods:
> >   public String getCurrencyString()
> >   public void setCurrencyString(String currency)
> >   protected void clearCurrencyStringCache()
> >
> >
> > Now that issue 210 (http://issues.apache.org/jira/browse/ADFFACES-210)
> has
> > been implemented
> > and we have a ClientRowKeyManager class that handles the
> > object-rowkey->string-key mapping, I'd like to propose the following
> > changes:
> > 1. rename get/setCurrentString to get/setClientRowKey
> > 2. remove the clearCurrencyStringCache method (ie: make it
> package-private).
> >
> > what do you think?
> >
> > If we do decide to implement these changes, I'd like to do them in two
> > parts:
> > 1. first add the new methods and deprecate the old ones.
> > 2. give a few days for dependent projects to upgrade and then remove the
> old
> > deprecated methods.
> >
> > is that ok?
> >
> > thanks
> > Arjuna
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message