incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benj Fayle" <bfa...@maketechnologies.com>
Subject RE: Building ADF on JDK 1.4
Date Wed, 31 May 2006 19:45:18 GMT
I would prefer to see ADF remain 1.4 compliant for some time as well. We
are currently using Java 1.5 for many new projects but there are still a
large number of our enterprise customers who will continue to use Java
1.4 for at least another year, possibly longer. It is for some of these
larger projects  that ADF is particularly attractive but they are
restricted to Java 1.4.

I would be willing to assist in this effort as well.

Benj Fayle

-----Original Message-----
From: Dan Robinson [mailto:dannyjrobinson@gmail.com] 
Sent: Wednesday, May 31, 2006 12:35 PM
To: adffaces-user@incubator.apache.org
Subject: Re: Building ADF on JDK 1.4

Thanks for the clarification.  Could someone confirm that this the final
decision for the Apache ADF code, or just the version as supplied by
Oracle.  A recent email on the MyFaces list as of February Sean
Schofield
said

"The ADF stuff is in incubation right now so there are all sorts of
possibilities for change.  I envision a lively discussion where discuss
the
pros and cons of allowing tomahawk, tobago or adf to use jdk
1.5functionality.  Currently tomahawk does not have any jdk
1.5 stuff (that I am aware of.)"

We're really wanting to use ADF for our application development, but are
currently hampered by the JDK 1.5 requirement, given not all App Servers
have made it to this JDK yet.  We're also wanting to deploy this
technology
to our existing users with 1.4 powered servers.

I don't believe that MyFaces (as of 1.1.2) has mandated this JVM
version, so
it seems strange for a library that runs on MyFaces to have this
restriction.  If there's support we could provide assistance in making
these
changes to allow 1.4.

Thanks ... and I wait to be corrected ;-)

D.

On 5/26/06, Gabrielle Crawford <gabrielle.crawford@oracle.com> wrote:
>
> ADF Faces requires 1.5.
>
> Thanks,
>
> Gabrielle
>
> Dan Robinson wrote:
>
> > Could anyone advise the steps to building ADF against JDK 1.4?  I
have
> it
> > building correctly using the Maven Wiki instructions which seem to
> > rely on
> > JDK 1.5.
> >
> > Many thanks,
> >
> > D.
> >
>
>

Mime
View raw message