incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias Wessendorf" <mat...@apache.org>
Subject Re: RE: Re: Re: Tag renaming proposal
Date Fri, 14 Jul 2006 00:19:13 GMT
> SO, to return to the most important question of the moment:
> I'm gonna assume that all of the "non-controversial" name changes
> have general approval, so that one of the committers can go ahead
> and make the change...  To review, that list is now:
>
> decorateCollection  panelCollection
> navigationLevel     navigationPane
> objectIcon          icon
> objectImage         image
> objectMedia         media
> objectSeparator     separator
> objectSpacer        spacer
> panelBorder         panelBorderLayout
> panelForm           panelFormLayout
> panelGroup          panelGroupLayout
> panelHorizontal     panelHorizontalLayout
> selectInputColor    inputColor
> selectInputDate     inputDate
> showOneAccordion    panelAccordion
> showManyAccordion   panelAccordion (merge with showOneAccordion)
> showOneChoice       panelChoice
> showOneRadio        panelRadio
> showOneTabs         panelTabbed


+1


> -- Adam
>
>
> On 7/13/06, Benj Fayle <bfayle@maketechnologies.com> wrote:
> > Agreed which is why abbreviations such as inputLOV should be avoided
> > inputListOfValues is much more self-explanatory.
> >
> > -----Original Message-----
> > From: Adam Winer [mailto:awiner@gmail.com]
> > Sent: Wednesday, July 12, 2006 10:13 AM
> > To: adffaces-user@incubator.apache.org
> > Subject: Re: Re: Re: Tag renaming proposal
> >
> > On 7/12/06, Mike Kienenberger <mkienenb@gmail.com> wrote:
> > >
> > > On 7/12/06, Matthias Wessendorf <matzew@apache.org> wrote:
> > > > > I've gotten a decent bit of feedback in the past that people
> > > > > just couldn't find selectInputDate or selectInputColor, but
> > > > > if they'd been called inputDate or inputColor, they would have
> > > > > been found.
> > > >
> > > > yes, that is true for me, to be honest .
> > >
> > > On the other hand, if someone explains up-front in the component table
> > > of contents that "input" meant unassisted entry and "select" meant
> > > assisted entry, and "inputSelect" means both, I could have figured
> > > this out.
> >
> >
> >
> > ... but as "selectInputDate", anyone looking alphabetically is just
> > totally
> > lost.
> >
> > One of the goals of the renaming is to minimize any need for up-front
> > explanation;  the best name is one that requires no documentation.
> >
> > -- Adam
> >
>


-- 
Matthias Wessendorf

further stuff:
blog: http://jroller.com/page/mwessendorf
mail: mwessendorf-at-gmail-dot-com

Mime
View raw message