incubator-adffaces-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mistry, Apurva" <amis...@nsf.org>
Subject problem with jsf rendered attribute
Date Wed, 14 Feb 2007 20:03:43 GMT
Hi, 
I am trying to simulate onpageLoad functionality in jsf. Basically, I
have put a rendered attribute in <tr:PanelFormLayout> tag -

<tr:panelFormLayout styleClass="x6b" rows="1" maxColumns="5"
rendered="#{EditCusLinksBB.ce}"> 
                    <tr:commandButton  text="Save"
action="#{EditCusLinksBB.saveAssoCE}"
rendered="#{EditCusLinksBB.actionType == 'NewCE'}"/>

                    <tr:commandButton  text="Edit"
action="#{EditCusLinksBB.editAssoCE}"
rendered="#{EditCusLinksBB.actionType == 'EditCE'}" />

                    
                <tr:inputListOfValues columns="10"
action="dialog:showParent" rendered="#{EditCusLinksBB.actionType ==
'NewCE'}"/>

                    <tr:outputText inlineStyle="x6m xag"
value="#{editCustBB.certifiedEntity.primaryCustomer.code}"
rendered="#{EditCusLinksBB.actionType != 'NewCE'}"/>

........ 
</tr:panelFormLayout> 


The goal is to perform some logic before the rest of the tags are
rendered inside panelformLayout gets rendered. 
But the rendered gets called 4 times, and the output from getCE() is
changing. 
I am not sure why is rendered called upon several time, whats the
alternative? 
Thanks 
Apurva. 

********************************************************************* 
 Confidentiality Notice:  This email message, including any attachments,
is for the sole use of the intended recipient(s) and may contain 
 confidential and privileged information. Any unauthorized review, use, 
 disclosure or distribution is prohibited. If you are not the intended 
 recipient, please contact the sender by email and destroy all copies of
the original message. 
********************************************************************* 


Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message