incubator-droids-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mingfai Ma (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (DROIDS-49) Make LinkTask.started non-final, and rename it propertly
Date Fri, 05 Jun 2009 07:18:07 GMT

    [ https://issues.apache.org/jira/browse/DROIDS-49?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12702061#action_12702061
] 

Mingfai Ma edited comment on DROIDS-49 at 6/5/09 12:16 AM:
-----------------------------------------------------------

changed to "Major"

after a deeper thought, it is wrong to call it "started". It is the task creation date, and
after creation, a task is put into a queue, and only when the task is polled from the queue
and being processed, it could be called as "started".

just rename it to "created" or "createdDate"?

besides, the lastModifiedDate is not called lastModified, so the use of "Date" suffix need
to be reviewed.

I personally like "created" and "lastModified" without the Date suffix but both are fine as
long as it is standardized.

      was (Author: mingfai):
    changed to "Major"

after a deeper thought, it is wrong to call it "started". It is the task creation date, and
after creation, a task is put into a queue, and only when the task is polled from the queue
and being processed, it could be called as "started".

just rename it to "created" or "createdDate"?

besides, the lastModifiedDate is not called lastModified, so the use of "Date" prefix need
to be reviewed.

I personally like "created" and "lastModified" without the Date prefix but both are fine as
long as it is standardized.
  
> Make LinkTask.started non-final, and rename it propertly
> --------------------------------------------------------
>
>                 Key: DROIDS-49
>                 URL: https://issues.apache.org/jira/browse/DROIDS-49
>             Project: Droids
>          Issue Type: Improvement
>          Components: core
>            Reporter: Mingfai Ma
>         Attachments: DROIDS-49.patch
>
>
> started/taskDate should be final, but it caused a problem to me in doing unit test that
a huge number of LinkTask are to be created with different started date
> my suggestion:
> 1. make started non-final
> 2. add a constructor 
> by design, the 2nd one is better. but in terms of maintainability, it's better not to
add too many constructors. 
> The HttpCore design has some examples (http header of response?! sth like that) that
final attributes are not necessarily be made as final/immune. I suggest just to make the started
field non-final.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message