incubator-droids-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mingfai <mingfai...@gmail.com>
Subject Re: Crawler
Date Sun, 21 Jun 2009 12:17:38 GMT
On Thu, Jun 18, 2009 at 6:32 PM, Thorsten Scherler <
thorsten.scherler.ext@juntadeandalucia.es> wrote:

> On Wed, 2009-06-17 at 13:14 +0100, Ross Gardler wrote:
> > [cc'd to droids list for info since I'm a mentor there too]
> >
> > 2009/6/17 Robert Burrell Donkin <robertburrelldonkin@blueyonder.co.uk>:
> > > Ross Gardler wrote:
> > >> 2009/6/17 Robert Burrell Donkin <robertburrelldonkin@blueyonder.co.uk
> >:
> > >>> i made a start on a crawler module yesterday to make it easier to
> > >>> download all releases from an URL.
> > >>
> > >> Why not use Droids?
> > >>
> > >> http://incubator.apache.org/droids/
> > >
> > > in terms of downloading tech...
> > >
> > > i did consider looking into droids but couldn't find a release and it
> > > required jdk 1.6 so concluded that it's not an immediate option (i
> > > needed something right away)
> >
> > Fair enough, maybe the Droids people will be prompted into makind a
> > release (JDK1.5 preferably)
>
> We are planing a release soonish I once wrote some 1.4 downward
> compilation with ant and retrotranslator (see
> http://svn.apache.org/viewvc/incubator/droids/trunk/build.xml?view=co).
> However meanwhile we switched to maven and I have not looked into the
> integration of retrotranslator in maven.
>

I don't like to restrict to Java 5 but as a framework/library, it's good to
support Java 5. For 1.4, I somehow think it's too much. but if the
retrotranslator will work magically, there is no harm to support it.

how does the retrotranslator work? do we need to avoid coding against any
Java 6 interface if we want to make Droids JDK 5 compatible? I suppose we
didn't depend on Java 6 yet. We should be able to use XML Streaming (StAX)
without Java 6.


regards,
mingfai

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message