incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Kolotyluk <eric.koloty...@gmail.com>
Subject Re: Tired of wagon
Date Wed, 28 Sep 2011 18:04:28 GMT
On 2011-09-26 4:42 PM, Brett Porter wrote:
> On 24/09/2011, at 8:00 AM, Eric Kolotyluk wrote:
>
>> OK, I do not understand why this is failing. Why do I keep seeing wagon: when it
should be looking in my Nexus respository?
>>
>> There seems to be a problem resolving net.sf.jni4net:jni4net.n:dotnet-library:0.8.5.1
and com.kodak.intersystem.dotnet:intersystem-jni4net:dotnet-library:0.0.2-SNAPSHOT
>>
>> but those artifacts are in my local repository, they are also in my Nexus repository,
and if I look in P:\Intersystem\main\platform.NET\intersystem-service\target I can see both
intersystem-jni4net.dll&  jni4net.n.dll
>>
>> I am really confused as to what is happening. Is it a configuration problem, or an
NPanday bug?
> Ok, I was finally able to trace through to where this might be coming from.
>
> It seems one of your POMs is using a com_reference, and the current code processes them
without looking in the locations provided by npanday-settings.xml. As a result, you need to
have both "tlbimp" and "reg" in your PATH. Is that the case?
>
> If they are in the path, they are failing when called but the output is being swallowed.
I've added some more debug logging for the next release to try and help some more with this.
You can find instructions on the site for building the version from trunk if you need to try
it.
>
> - Brett
>
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> http://au.linkedin.com/in/brettporter
OK, I did not have tlbimp.exe on my PATH, so I added it and made a 
little more progress, but the build is still failing (see below).

I am not clear why there are complaints about missing assembly 
references. As far as I can tell they seem to be there.

Part of the problems seems to be that 
P:\Intersystem\main\platform.NET\intersystem-service\target\ does not 
have the directory 28104638. Is this something that NPanday is supposed 
to create? Is this because of the previous errors?

Cheers, Eric

------------------------------------------------------------------
Executing Maven
Pom File: P:\Intersystem\main\platform.NET\intersystem-service\pom.xml
Goal: compile
Arguments: compile
NPanday Command: P:\Tools\Windows\x86\Apache\Maven 3.0.3\bin\mvn.bat compile


------------------------------------------------------------------


[INFO] Scanning for projects...
[INFO]
[INFO] 
------------------------------------------------------------------------
[INFO] Building Intersystem Windows Service 0.0.2-SNAPSHOT
[INFO] 
------------------------------------------------------------------------
[INFO]
[INFO] --- maven-compile-plugin:1.4.0-incubating:initialize 
(default-initialize) @ intersystem-service ---
SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in 
[jar:file:/C:/Users/10069959/.m2/repository/org/sonatype/gossip/gossip/1.0/gossip-1.0.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in 
[jar:file:/C:/Users/10069959/.m2/repository/org/slf4j/slf4j-jdk14/1.5.11/slf4j-jdk14-1.5.11.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an 
explanation.
28-Sep-2011 10:46:34 AM npanday.dao.impl.ProjectDaoImpl 
storeProjectAndResolveDependencies
WARNING: NPANDAY-180-018: Not found in local repository, now retrieving 
artifact from wagon:net.sf.jni4net:jni4net.n:dotnet-library:0.8.5.1, 
Failed Path Check = 
P:\Intersystem\main\platform.NET\intersystem-service\target\jni4net.n.dll
28-Sep-2011 10:46:34 AM npanday.PathUtil getDotNetArtifact
WARNING:
NPANDAY-1005-0001: Error copying dependency 
com.kodak.intersystem.dotnet:intersystem-jni4net:dotnet-library:0.0.2-SNAPSHOT:compile 
File 
C:\Users\10069959\.m2\repository\com\kodak\intersystem\dotnet\intersystem-jni4net\0.0.2-20110927.221115-3\intersystem-jni4net-0.0.2-20110927.221115-3.dll

does not exist
28-Sep-2011 10:46:34 AM npanday.dao.impl.ProjectDaoImpl 
storeProjectAndResolveDependencies
WARNING: NPANDAY-180-018: Not found in local repository, now retrieving 
artifact from 
wagon:com.kodak.intersystem.dotnet:intersystem-jni4net:dotnet-library:0.0.2-SNAPSHOT, 
Failed Path Check = 
P:\Intersystem\main\platform.NET\intersystem-service\target\intersystem-jni4net.dll
28-Sep-2011 10:46:34 AM npanday.dao.impl.ProjectDaoImpl 
storeProjectAndResolveDependencies
WARNING: NPANDAY-180-018: Not found in local repository, now retrieving 
artifact from wagon:net.sf.jni4net:jni4net.n:dotnet-library:0.8.5.1, 
Failed Path Check = 
P:\Intersystem\main\platform.NET\intersystem-service\target\jni4net.n.dll
[INFO] Mojo Execution Time = 542
[INFO]
[INFO] --- maven-resolver-plugin:1.4.0-incubating:resolve 
(default-resolve) @ intersystem-service ---
[INFO] Mojo Execution Time = 1
[INFO]
[INFO] --- 
NPanday.Plugin.Settings.JavaBinding:1.4.0-incubating:generate-settings 
(default-generate-settings) @ intersystem-service ---
[INFO]
[INFO] --- maven-compile-plugin:1.4.0-incubating:generate-assembly-info 
(default-generate-assembly-info) @ intersystem-service ---
[INFO] NPANDAY-902-001: Found AssemblyInfo file(s), so will not generate one
[INFO]
[INFO] --- maven-compile-plugin:1.4.0-incubating:process-sources 
(default-process-sources) @ intersystem-service ---
[INFO] NPANDAY-904-002: Copying source files: From = 
P:\Intersystem\main\platform.NET\intersystem-service,  To = 
P:\Intersystem\main\platform.NET\intersystem-service\target/build-sources, 
File Count = 6
[INFO]
[INFO] --- maven-compile-plugin:1.4.0-incubating:process-test-sources 
(default-process-test-sources) @ intersystem-service ---
[INFO] NPANDAY-905-001: No test source files to copy
[INFO]
[INFO] --- maven-resgen-plugin:1.4.0-incubating:copy-resources 
(default-copy-resources) @ intersystem-service ---
[INFO] NPANDAY-1500-003: Copied resource directory: Number of Resources 
= 7, Resource Directory = 
P:\Intersystem\main\platform.NET\intersystem-service, Destination 
Directory = 
P:\Intersystem\main\platform.NET\intersystem-service\target\assembly-resources\resource\assembly-resources
[INFO] NPANDAY-1500-003: Copied resource directory: Number of Resources 
= 0, Resource Directory = 
P:\Intersystem\main\platform.NET\intersystem-service\src\test\resources, 
Destination Directory = 
P:\Intersystem\main\platform.NET\intersystem-service\target\assembly-resources\resource\assembly-resources
[INFO]
[INFO] --- maven-resgen-plugin:1.4.0-incubating:generate 
(default-generate) @ intersystem-service ---
[INFO]
[INFO] --- 
maven-resgen-plugin:1.4.0-incubating:generate-existing-resx-to-resource 
(default-generate-existing-resx-to-resource) @ intersystem-service ---
[INFO]
[INFO] --- maven-compile-plugin:1.4.0-incubating:compile 
(default-compile) @ intersystem-service ---
[INFO] NPANDAY-066-013: Found Vendor = Vendor = MICROSOFT, Vendor 
Version = 4.0, Framework Version = 4.0, Executable Paths = 
[C:\Windows\Microsoft.NET\Framework64\v4.0.30319, C:\Program Files 
(x86)\Microsoft SDKs\Windows\v7.0A\Bin\NETFX 4.0 Tools]
[INFO] NPANDAY-068-003: Compiling Artifact: Vendor = MICROSOFT, Language 
= MICROSOFT, Assembly Name = 
P:\Intersystem\main\platform.NET\intersystem-service\target\intersystem-service.exe
[INFO] NPANDAY-068-005: Found executable path for csc: 
C:\Windows\Microsoft.NET\Framework64\v4.0.30319
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\IntersystemService.cs(23,17):

error CS0234: The type or namespace name 'TeamFoundation' does not exist 
in the namespace 'Microsoft' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\IntersystemService.cs(53,39):

error CS0234: The type or namespace name 'Service' does not exist in the 
namespace 'com.kodak.intersystem.service' (are you missing an assembly 
reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(11,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(11,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(12,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(12,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(13,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(13,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(14,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(14,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(15,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
p:\Intersystem\main\platform.NET\intersystem-service\target\28104638\intersystem-service_Content.g.i.cs(15,27):

error CS0234: The type or namespace name 'Resources' does not exist in 
the namespace 'System.Windows' (are you missing an assembly reference?)
[INFO] 
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] 
------------------------------------------------------------------------
[INFO] Total time: 5.706s
[INFO] Finished at: Wed Sep 28 10:46:38 PDT 2011
[INFO] Final Memory: 11M/368M
[INFO] 
------------------------------------------------------------------------
[ERROR] Failed to execute goal 
org.apache.npanday.plugins:maven-compile-plugin:1.4.0-incubating:compile 
(default-compile) on project intersystem-service: NPANDAY-900-006: 
Unable to Compile: Language = C_SHARP, Vendor = null, ArtifactType = 
dotnet-executable, Source Directory = 
P:\Intersystem\main\platform.NET\intersystem-service: NPANDAY-040-001: 
Could not execute: Command =  cmd.exe /X /C "csc 
@P:\Intersystem\main\platform.NET\intersystem-service\target\28104638\responsefile.rsp", 
Result = 1 -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the 
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, 
please read the following articles:
[ERROR] [Help 1] 
http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
NPanday Execution Failed!, with exit code: 1


<?xml version="1.0" encoding="utf-8"?>
<npandaySettings xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<operatingSystem>Microsoft Windows NT 6.1.7600.0</operatingSystem>
<defaultSetup>
<vendorName>MICROSOFT</vendorName>
<vendorVersion>2.0.50727</vendorVersion>
<frameworkVersion>2.0.50727</frameworkVersion>
</defaultSetup>
<vendors>
<vendor>
<vendorName>MICROSOFT</vendorName>
<vendorVersion>2.0.50727</vendorVersion>
<frameworks>
<framework>
<frameworkVersion>2.0.50727</frameworkVersion>
<installRoot>C:\Windows\Microsoft.NET\Framework64\v2.0.50727</installRoot>
<sdkInstallRoot>C:\Program Files\Microsoft.NET\SDK\v2.0 
64bit\</sdkInstallRoot>
<executablePaths>
<executablePath>C:\Program Files\Microsoft.NET\SDK\v2.0 
64bit\bin</executablePath>
</executablePaths>
</framework>
</frameworks>
</vendor>
<vendor>
<vendorName>MICROSOFT</vendorName>
<vendorVersion>3.0</vendorVersion>
<frameworks>
<framework>
<frameworkVersion>3.0</frameworkVersion>
<installRoot>C:\Windows\Microsoft.NET\Framework64\v3.0</installRoot>
<sdkInstallRoot>C:\Program Files\Microsoft.NET\SDK\v2.0 
64bit\</sdkInstallRoot>
<executablePaths>
<executablePath>C:\Windows\Microsoft.NET\Framework64\v2.0.50727</executablePath>
<executablePath>C:\Program Files\Microsoft.NET\SDK\v2.0 
64bit\bin</executablePath>
</executablePaths>
</framework>
</frameworks>
</vendor>
<vendor>
<vendorName>MICROSOFT</vendorName>
<vendorVersion>3.5</vendorVersion>
<frameworks>
<framework>
<frameworkVersion>3.5</frameworkVersion>
<installRoot>C:\Windows\Microsoft.NET\Framework64\v3.5</installRoot>
<sdkInstallRoot>C:\Program Files (x86)\Microsoft 
SDKs\Windows\v7.0A\Bin\</sdkInstallRoot>
</framework>
</frameworks>
</vendor>
<vendor>
<vendorName>MICROSOFT</vendorName>
<vendorVersion>4.0</vendorVersion>
<frameworks>
<framework>
<frameworkVersion>4.0</frameworkVersion>
<installRoot>C:\Windows\Microsoft.NET\Framework64\v4.0.30319</installRoot>
<sdkInstallRoot>C:\Program Files (x86)\Microsoft 
SDKs\Windows\v7.0A\Bin\NETFX 4.0 Tools\</sdkInstallRoot>
</framework>
</frameworks>
</vendor>
</vendors>
</npandaySettings>

Mime
View raw message