incubator-npanday-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Kolotyluk <>
Subject Re: Getting Started
Date Mon, 03 Mar 2014 17:57:41 GMT
See below...

On 3/1/2014 8:05 PM, Brett Porter wrote:
> On 28 Feb 2014, at 3:01 am, Eric Kolotyluk <> wrote:
>> D:\Users\Eric\Software\Project\Repositories\net\kolotyluk\windows\elevate>mvn
archetype:generate -DarchetypeArtifactId=maven-archetype-dotnet-simple -DarchetypeGroupId=npanday
> I guess the guide wasn't clear that you need to substitute the version in here. It should
be set to 1.5.0-incubating-SNAPSHOT if you are using the MSI. (It might work without specifying
the version at all, but I don't have my VM here to verify at the moment).

No, the guide is not very clear on many topics. In particular, there are 
few things better than a concrete example, as prototypes are often open 
to ambiguous interpretation. In general it is useful to have both 
prototype examples, and concrete examples.

I tried using

mvn archetype:generate 

  but that prints a list of 930 archetypes, and asks me to pick one. Not 
very user friendly, and when I enter "npanday" it does not find anything.

>> Is there some other repository I need to configure in my Maven settings? Why aren't
the necessary NPanday pieces in Maven Central?
> They are in central, but only the last release is there, not any snapshots. There are
some additional artifacts required from

I tried configuring that remote repository into the settings.xml file 
and my nexus server, but that does not seem to work. Here is what I put 
in my settings.xml

               <name>Aduna Software</name>

Is there something else I should be configuring there?

archetype:generate -DarchetypeArtifactId=maven-archetype-dotnet-simple 
-DarchetypeGroupId=npanday -DarchetypeVersion=1.5.0-incubating-SNAPSHOT
[INFO] Scanning for projects...
[INFO] Building Maven Stub Project (No POM) 1
[INFO] >>> maven-archetype-plugin:2.2:generate (default-cli) @ 
standalone-pom >>>
[INFO] <<< maven-archetype-plugin:2.2:generate (default-cli) @ 
standalone-pom <<<
[INFO] --- maven-archetype-plugin:2.2:generate (default-cli) @ 
standalone-pom ---
[INFO] Generating project in Interactive mode
[WARNING] Archetype not found in any catalog. Falling back to central 
repository (
[WARNING] Use -DarchetypeRepository=<your repository> if archetype's 
repository is elsewhere.
[INFO] Total time: 4.573s
[INFO] Finished at: Mon Mar 03 09:49:46 PST 2014
[INFO] Final Memory: 32M/1963M
[ERROR] Failed to execute goal 
(default-cli) on project standalone-pom: The desired archetype does not 
exist (npanday:maven-archetype-dotnet-simple:1.5.0-incubating-SNAPSHOT) 
-> [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the 
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, 
please read the following articles:
[ERROR] [Help 1]

Cheers, Eric

> - Brett

View raw message