incubator-photark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nick choi <n1xx...@gmail.com>
Subject Re: Building the Apache PhotArk Problem
Date Tue, 23 Feb 2010 08:30:37 GMT
Now I can build photark.

Thank you.

On 23 February 2010 12:48, Luciano Resende <luckbr1975@gmail.com> wrote:

> On Mon, Feb 22, 2010 at 5:35 PM, nick choi <n1xx.kr@gmail.com> wrote:
> > I just checkout PhotArk's trunk. And then I tried to build PhotArk with
> > maven.
> > But I got error messages even tough I setup like BUILDING document in
> trunk.
> >
> > I guess there is no resource about *org.apache:apache:pom:4* in
> repository.
> > Of course, I checked the URL,
> >
> http://people.apache.org/repo/m2-incubating-repository/org/apache/apache/4
> > But I can't find it.
> >
> > What can I do to build PhotArk?
> >
> > Here is My test environment
> > JDK 1.6.0
> > maven 2.2.1
> > OS : Ubuntu 9.10 x86_64
> >
> >
> > Thank you.
> >
> > [INFO] Scanning for projects...
> > Downloading:
> >
> http://people.apache.org/repo/m2-incubating-repository/org/apache/apache/4/apache-4.pom
> > [INFO] Unable to find resource 'org.apache:apache:pom:4' in repository
> > apache.incubator (http://people.apache.org/repo/m2-incubating-repository
> )
> > Downloading:
> http://repo1.maven.org/maven2/org/apache/apache/4/apache-4.pom
> > [WARNING] Unable to get resource 'org.apache:apache:pom:4' from
> repository
> > central (http://repo1.maven.org/maven2): Specified destination directory
> > cannot be created: /home/nick/.m2/repository/org/apache/apache/4
> >
> >
> > [INFO]
> > ------------------------------------------------------------------------
> >
> > [ERROR] FATAL ERROR
> >
> >
> > [INFO]
> > ------------------------------------------------------------------------
> >
> > [INFO] Error building POM (may not be this project's POM).
> >
> >
> >
> >
> > Project ID: org.apache.photark:photark-parent:pom:1.0-incubating-SNAPSHOT
> >
> > Reason: Cannot find parent: org.apache:apache for project:
> > org.apache.photark:photark-parent:pom:1.0-incubating-SNAPSHOT for project
> > org.apache.photark:photark-parent:pom:1.0-incubating-SNAPSHOT
> >
> >
> >
> >
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Trace
> >
> > org.apache.maven.reactor.MavenExecutionException: Cannot find parent:
> > org.apache:apache for project:
> > org.apache.photark:photark-parent:pom:1.0-incubating-SNAPSHOT for project
> > org.apache.photark:photark-parent:pom:1.0-incubating-SNAPSHOT
> >
> >        at
> org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:404)
> >
> >
> >        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:272)
> >
> >
> >        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
> >
> >
> >        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
> >
> >
> >        at
> > org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
> >
> >        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >
> >
> >        at
> >
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> >
> >        at
> >
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> >
> >        at java.lang.reflect.Method.invoke(Method.java:597)
> >
> >
> >        at
> > org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
> >
> >        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
> >
> >
> >        at
> > org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> >
> >        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> >
> >
> > Caused by: org.apache.maven.project.ProjectBuildingException: Cannot find
> > parent: org.apache:apache for project:
> > org.apache.photark:photark-parent:pom:1.0-incubating-SNAPSHOT for project
> > org.apache.photark:photark-parent:pom:1.0-incubating-SNAPSHOT
> >
> >        at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1396)
> >
> >        at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:823)
> >        at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:508)
> >        at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:200)
> >        at org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:604)
> >        at
> > org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:487)
> >        at
> org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:391)
> >        ... 12 more
> > Caused by: org.apache.maven.project.ProjectBuildingException: POM
> > 'org.apache:apache' not found in repository: Unable to download the
> artifact
> > from any repository
> >
> >  org.apache:apache:pom:4
> >
> > from the specified remote repositories:
> >  central (http://repo1.maven.org/maven2),
> >  apache.incubator (
> http://people.apache.org/repo/m2-incubating-repository)
> >
> >  for project org.apache:apache
> >        at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:605)
> >        at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1392)
> >        ... 18 more
> > Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException:
> > Unable to download the artifact from any repository
> >
> >  org.apache:apache:pom:4
> >
> > from the specified remote repositories:
> >  central (http://repo1.maven.org/maven2),
> >  apache.incubator (
> http://people.apache.org/repo/m2-incubating-repository)
> >
> >
> >        at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:228)
> >        at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:90)
> >        at
> >
> org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:558)
> >        ... 19 more
> > Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable
> to
> > download the artifact from any repository
> >        at
> >
> org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:404)
> >        at
> >
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:216)
> >        ... 21 more
> >
>
>
> There might be some infrastructure maintenance going on...
> Could you please try in about 30 mins with the command below and let
> me know if you still see problems... or you could try to configure
> some mirrors in your settings.xml
>
>   mvn -U clean install
>
> --
> Luciano Resende
> http://people.apache.org/~lresende
> http://twitter.com/lresende1975
> http://lresende.blogspot.com/
>



-- 
Nick Choi.
http://blog.n1xx.net

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message