incubator-photark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pascal GILLET (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (PHOTARK-79) core JAX-WS API not present in JDK 1.5
Date Thu, 19 Apr 2012 22:30:43 GMT

     [ https://issues.apache.org/jira/browse/PHOTARK-79?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pascal GILLET updated PHOTARK-79:
---------------------------------

        Fix Version/s:     (was: PhotArk M1)
                       PhotArk M4
    Affects Version/s:     (was: PhotArk M1)
                       PhotArk M4
    
> core JAX-WS API not present in JDK 1.5
> --------------------------------------
>
>                 Key: PHOTARK-79
>                 URL: https://issues.apache.org/jira/browse/PHOTARK-79
>             Project: PhotArk
>          Issue Type: Bug
>          Components: Build Infrastructure
>    Affects Versions: PhotArk M4
>         Environment: JDK 1.5
>            Reporter: Pascal GILLET
>            Priority: Minor
>              Labels: patch
>             Fix For: PhotArk M4
>
>         Attachments: compile-error.txt, photark-flickr-pom.patch
>
>
> On the PhotArk Developer Guide, it is said that the required version of the JDK is at
least 1.5. But in this case, the photark-flickr component cannot compile as the class javax.xml.ws.http.HTTPException,
that is part of the JAX-WS API, is not included in the Java 5 API.
> The dependency to the JAX-WS API should be added in the POM within a profile automatically
triggered when the JDK's version is 1.5, as following:
> <profiles>
>    <profile>
>       <id>jdk15</id>
>       <activation>
>          <jdk>1.5</jdk>
>       </activation>
>       <dependencies>
>          <dependency>
>             <groupId>javax.xml.ws</groupId>
>             <artifactId>jaxws-api</artifactId>
>             <version>2.2.8</version>
>          </dependency>
>       </dependencies>
>    </profile>
> </profiles>
> OR the required JDK's version should be 6.0 at least...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message