incubator-stonehenge-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Dewey <>
Subject RE: JAVA_OPSSEC not working
Date Wed, 08 Jul 2009 02:31:53 GMT
I have WSAS_OPSSEC working in my lab, I can test SH-67, and see if it works for me.


-----Original Message-----
From: Drew Baird (Volt) [] 
Sent: Tuesday, July 07, 2009 10:10 PM
Subject: RE: JAVA_OPSSEC not working

Is this is blocker to commit for SH-67?
I definitely think SH-67 should commit before METRO is committed.


From: Avantika Agrawal []
Sent: Tuesday, July 07, 2009 1:58 PM
Subject: JAVA_OPSSEC not working

I am unable to process orders using the JAVA_OPSSEC. I tried processing with the JAVA_OPS
and that works fine.
Here are some more details - when I tried using DOTNET_CLIENT -> JAVA_BS -> JAVA_OPSSEC
to place an order, I get this error:
org.apache.axis2.AxisFault: Error during encryption
Description: An unhandled exception occurred during the execution of the current web request.
Please review the stack trace for more information about the error and where it originated
in the code.

Exception Details: System.ServiceModel.FaultException: org.apache.axis2.AxisFault: Error during

Source Error:

Line 309:                throw;
Line 310:            }
Line 311:        }
Line 312:
Line 313:        /// <summary>

Source File: C:\dotnet\trader_client\StockTraderWebApplicationClients\BusinessServiceClient.cs
   Line: 311

Stack Trace:

[FaultException: org.apache.axis2.AxisFault: Error during encryption]
   System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage
retMsg) +10257466
   System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32
type) +539 userID, String symbol, Double quantity,
Int32 orderProcessingMode) +0 userID, String
symbol, Double quantity, Int32 orderProcessingMode) in C:\dotnet\trader_client\StockTraderWebApplicationClients\BusinessServiceClient.cs:311 userID, String symbol,
Double quantity) in C:\dotnet\trader_client\StockTraderWebApplicationClients\BSLClient.cs:435
   Trade.Web.Order.Page_Load(Object sender, EventArgs e) in c:\dotnet\trader_client\Trade\Order.aspx.cs:60
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs
e) +25
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +42
   System.Web.UI.Control.OnLoad(EventArgs e) +132
   System.Web.UI.Control.LoadRecursive() +66
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Let me know if anyone else has faced this issue or if it is something that I have forgotten
to set up. If not, I can write up a formal bug on the JIRA.


View raw message