jackrabbit-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From resc...@apache.org
Subject svn commit: r1858427 - /jackrabbit/branches/2.16/RELEASE-NOTES.txt
Date Tue, 30 Apr 2019 13:06:05 GMT
Author: reschke
Date: Tue Apr 30 13:06:04 2019
New Revision: 1858427

URL: http://svn.apache.org/viewvc?rev=1858427&view=rev
Log:
JCR-4431: Release Jackrabbit 2.16.4 - Candidate Release Notes

Modified:
    jackrabbit/branches/2.16/RELEASE-NOTES.txt

Modified: jackrabbit/branches/2.16/RELEASE-NOTES.txt
URL: http://svn.apache.org/viewvc/jackrabbit/branches/2.16/RELEASE-NOTES.txt?rev=1858427&r1=1858426&r2=1858427&view=diff
==============================================================================
--- jackrabbit/branches/2.16/RELEASE-NOTES.txt (original)
+++ jackrabbit/branches/2.16/RELEASE-NOTES.txt Tue Apr 30 13:06:04 2019
@@ -1,13 +1,13 @@
-Release Notes -- Apache Jackrabbit -- Version 2.16.3
+Release Notes -- Apache Jackrabbit -- Version 2.16.4
 
 Introduction
 ------------
 
-This is Apache Jackrabbit(TM) 2.16.3, a fully compliant implementation of the
+This is Apache Jackrabbit(TM) 2.16.4, a fully compliant implementation of the
 Content Repository for Java(TM) Technology API, version 2.0 (JCR 2.0) as
 specified in the Java Specification Request 283 (JSR 283).
 
-Apache Jackrabbit 2.16.3 is an incremental feature release based on
+Apache Jackrabbit 2.16.4 is an incremental feature release based on
 and compatible with earlier stable Jackrabbit 2.x releases. Jackrabbit
 2.16.x releases are considered stable and targeted for production use.
 
@@ -17,39 +17,68 @@ The minimum Java version for this releas
   
 for maintenance versions that support earlier Java versions.  
 
-Changes in Jackrabbit 2.16.3
+Changes in Jackrabbit 2.16.4
 ----------------------------
 
 Bug
 
-    [JCR-4317] - davex remoting fails for non-ASCII characters in node names
-    [JCR-4324] - NPE on Version.getLinearPredecessor() implementation
-
-Improvement
-
-    [JCR-3211] - Support HTTP proxy in SPI2DAV
+    [JCR-4120] - Spi2DavexRepositoryServiceImpl always hardcodes the default workspace name
to "default"
+    [JCR-4339] - Indexing configuration condition property seems to be broken
+    [JCR-4387] - Incorrect exception message when same-name-sibling is prevented on import
+    [JCR-4408] - jackrabbit-webapp: test dependency for httpcore breaks war file
+    [JCR-4420] - Release Notes: term "SHA1" no longer allowed
 
 Task
 
-    [JCR-4301] - get rid of JSR 305 dependency
-    [JCR-4302] - BTreeManager: fix Eclipse compiler error
-    [JCR-4304] - update Jetty to supported version 9.2.*
-    [JCR-4307] - Update animal-sniffer-maven-plugin to 1.16
-    [JCR-4318] - Update failsafe and surefire plugin versions to 2.22.0
-    [JCR-4320] - Update spotbugs plugin to 3.1.5
-    [JCR-4321] - Update maven plugins from org.apache.maven.plugins
-    [JCR-4322] - Consistent use of log4j versions
-    [JCR-4323] - webapp: update Tomcat dependency to 8.5.32
-    [JCR-4326] - Update aws java sdk version to 1.11.330 (consistent with Oak)
-    [JCR-4327] - Update httpcore dependency to 4.4.10
-    [JCR-4331] - Update httpclient dependency to 4.5.6
-    [JCR-4332] - Update httpmime dependency to 4.5.6
-    [JCR-4333] - Update javax.transaction dependency to 1.3
+    [JCR-4229] - Remove Oak dependency in webapp
+    [JCR-4336] - Upgrade commons-dbcp dependencies
+    [JCR-4342] - remove unused JSR 305 dependency from pom
+    [JCR-4343] - Update commons-vfs2 version to 2.2
+    [JCR-4344] - Update h2db version to latest stable 1.4.196
+    [JCR-4345] - Update mockito dependency to 2.20.0
+    [JCR-4346] - Update easymock dependency to 3.6
+    [JCR-4347] - Update com.jcraft.jsch dependency to 0.1.54
+    [JCR-4348] - Update osgi (compendium, core) dependencies
+    [JCR-4349] - Update plexus-utils dependency to 3.1.0
+    [JCR-4350] - jackrabbit-jcr-servlet: remove special-cased servlet-api dependency
+    [JCR-4359] - update maven-bundle-plugin to 3.5.0
+    [JCR-4360] - update maven-scr-plugin to 1.26.0
+    [JCR-4361] - Update spotbugs plugin to 3.1.6
+    [JCR-4362] - Update tomcat dependency to 8.5.33
+    [JCR-4363] - Update mockito dependency to 2.21.0
+    [JCR-4364] - update org.apache.felix.scr.annotations dependency to 1.12.0
+    [JCR-4365] - Update cglib dependency to 3.2.8
+    [JCR-4367] - Update htmlunit test dependency to 2.32
+    [JCR-4368] - Update commons-cli dependency to 1.4
+    [JCR-4371] - Update tika dependency to 1.19
+    [JCR-4372] - Update mockito dependency to 2.22.0
+    [JCR-4373] - webapp: update Tomcat dependency to 8.5.34
+    [JCR-4374] - webapp: update htmlunit dependency to 2.33
+    [JCR-4375] - Update jetbrains dependency to 16.0.3
+    [JCR-4379] - Update tika dependency to 1.19.1
+    [JCR-4381] - Update failsafe and surefire plugin versions to 2.22.1
+    [JCR-4382] - Update spotbugs plugin to 3.1.7
+    [JCR-4383] - Update animal-sniffer-maven-plugin to 1.17
+    [JCR-4384] - Update maven-bundle-plugin to 4.0.0
+    [JCR-4385] - Update maven-war-plugin to 3.2.2
+    [JCR-4386] - remove unused jxr dependency
+    [JCR-4388] - Update mockito dependency to 2.23.0
+    [JCR-4400] - Update tika dependency to 1.20
+    [JCR-4403] - update spotbugs dependency to 3.1.10
+    [JCR-4404] - update maven-assembly-plugin dependency to 3.1.1
+    [JCR-4405] - update maven-jar-plugin dependency to 3.1.1
+    [JCR-4406] - update maven-bundle-plugin dependency to 4.1.0
+    [JCR-4407] - Update httpcore dependency to 4.4.11
+    [JCR-4409] - jackrabbit-webapp: embed JCR 2.0 API
+    [JCR-4410] - jackrabbit-webapp: cleanup left over Oak references
+    [JCR-4411] - Update httpclient/mime dependencies to 4.5.7
+    [JCR-4415] - Update Jetty dependency to 9.2.26.v20180806
+    [JCR-4416] - Update slf4j dependency to 1.7.26
+    [JCR-4422] - Update httpclient/mime dependencies to 4.5.8
 
 Sub-task
 
-    [JCR-4306] - switch to findbugs replacement that is still maintained (spotbugs)
-    [JCR-4338] - avoid use of javax.rmi.PortableRemoteObject (removed in Java 11)
+    [JCR-4357] - upgrade to Jacoco version compatible with Java 11
 
 
 For more detailed information about all the changes in this and other



Mime
View raw message