jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "angela (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-497) No LoginModules configured error on Java 7
Date Fri, 14 Dec 2012 12:20:12 GMT

    [ https://issues.apache.org/jira/browse/OAK-497?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13532264#comment-13532264
] 

angela commented on OAK-497:
----------------------------

exactly... and still don't like it but i didn't see jukka's commit in the first place.
i will add a fixme comment as reminder that we should review it again.
                
> No LoginModules configured error on Java 7
> ------------------------------------------
>
>                 Key: OAK-497
>                 URL: https://issues.apache.org/jira/browse/OAK-497
>             Project: Jackrabbit Oak
>          Issue Type: Bug
>          Components: core
>         Environment: java version "1.7.0_04"
> Java(TM) SE Runtime Environment (build 1.7.0_04-b20)
> Java HotSpot(TM) 64-Bit Server VM (build 23.0-b21, mixed mode)
>            Reporter: Jukka Zitting
>            Assignee: Jukka Zitting
>             Fix For: 0.6
>
>
> The AuthenticationConfigurationImpl uses Configuration.getConfiguration() to get JAAS
configuration when available, and falls back to the default OakConfiguration when not.
> That fallback is currently triggered by a SecurityException thrown from getConfiguration(),
which seems to *not* happen on Java 7 where instead just an empty Configuration is returned.
> A better approach might be to check if the returned configuration (if any) contains entries
for the specified appName, and to fall back to default configuration if not.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message