jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-815) Wrong type for empty multi-valued property
Date Tue, 14 May 2013 12:13:15 GMT

    [ https://issues.apache.org/jira/browse/OAK-815?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13656995#comment-13656995
] 

Jukka Zitting commented on OAK-815:
-----------------------------------

Indeed, let's follow up there.
                
> Wrong type for empty multi-valued property
> ------------------------------------------
>
>                 Key: OAK-815
>                 URL: https://issues.apache.org/jira/browse/OAK-815
>             Project: Jackrabbit Oak
>          Issue Type: Bug
>          Components: core, jcr
>    Affects Versions: 0.7
>            Reporter: Marcel Reutegger
>             Fix For: 0.8
>
>         Attachments: 0001-OAK-815-Wrong-type-for-empty-multi-valued-property.patch
>
>
> While implementing JCR versioning in Oak I noticed that the type for a multi-valued property
with an empty array returns the wrong type. E.g. this happens when a node is checked in and
the jcr:predecessors property is set to an empty array. Property.getType() then says it's
of type STRING, while in fact it should say it's of type REFERENCE.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message