jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vikas Saurabh (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-2310) [Property Index] Adding new propertyName to an existing index doesn't update index to reflect the same
Date Mon, 01 Dec 2014 14:45:13 GMT

    [ https://issues.apache.org/jira/browse/OAK-2310?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14229856#comment-14229856
] 

Vikas Saurabh commented on OAK-2310:
------------------------------------

bq. what about setting the reindex flag to true?
I tried that but it didn't _seem_ to work :-/. It could also be the case that re-indexing
was going on but I couldn't find any logs despite {{DEBUG}} on o.a.j.o.query.

For my case, I had to resort to {{org.apache.jackrabbit.oak: "async" ("PropertyIndexAsyncReindex")}}->{{startPropertyIndexAsyncReindex()}}
jmx to forcefully re-create the index.

Also, I had the index as {{async}}. I'm not sure if it's relevant to the issue. BTW, [~tmueller]
had suggested that it's better to have one propertyName per index defn for performance reasons
-- so, we've changed our index defs accordingly.

> [Property Index] Adding new propertyName to an existing index doesn't update index to
reflect the same
> ------------------------------------------------------------------------------------------------------
>
>                 Key: OAK-2310
>                 URL: https://issues.apache.org/jira/browse/OAK-2310
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: query
>            Reporter: Vikas Saurabh
>            Priority: Critical
>
> It seems intuitive to add multiple property names to a given property index. But, currently,
adding a new {{propertyName}} to an existing index doesn't update indexed content to reflect
the newly added property name.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message