jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tommaso Teofili (JIRA)" <j...@apache.org>
Subject [jira] [Created] (OAK-6412) Consider upgrading to newer Lucene versions
Date Mon, 03 Jul 2017 09:41:00 GMT
Tommaso Teofili created OAK-6412:
------------------------------------

             Summary: Consider upgrading to newer Lucene versions
                 Key: OAK-6412
                 URL: https://issues.apache.org/jira/browse/OAK-6412
             Project: Jackrabbit Oak
          Issue Type: Improvement
          Components: lucene
            Reporter: Tommaso Teofili
            Assignee: Tommaso Teofili
             Fix For: 1.8


An year ago I had started prototyping the upgrade to Lucene 5 [1], in the meantime version
6 (and 7 soon) has come out.
I think it'd be very nice to upgrade Lucene version to the latest, this would give us improvements
in space consumption and runtime performance.
In case we want to upgrade to 6.0 or later we need to consider upgrade scenarios because Lucene
Codecs are backward compatible with the previous major release, so Lucene 6 can read Lucene
5 but not Lucene 4.x (4.7 in our case) therefore we would need to detect that when reading
an index and trigger and reindex using the new format.
Related to that there's also a patch to upgrade Solr index to version 5 (see OAK-4318).

[1] : https://github.com/tteofili/jackrabbit-oak/tree/lucene5



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message