jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] [Commented] (OAK-6687) ReadOnly connection to fresh SegmentNodeStore setup failing
Date Tue, 17 Oct 2017 14:22:00 GMT

    [ https://issues.apache.org/jira/browse/OAK-6687?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16207699#comment-16207699
] 

Michael Dürig commented on OAK-6687:
------------------------------------

This is caused by OAK-6840

> ReadOnly connection to fresh SegmentNodeStore setup failing
> -----------------------------------------------------------
>
>                 Key: OAK-6687
>                 URL: https://issues.apache.org/jira/browse/OAK-6687
>             Project: Jackrabbit Oak
>          Issue Type: Bug
>          Components: segment-tar
>            Reporter: Chetan Mehrotra
>            Priority: Minor
>              Labels: tooling
>             Fix For: 1.8
>
>
> Started a server with Oak version 1.7.7 and tried to connect oak-run-1.7.7 to same setup.
This resulted in following exception
> {noformat}
> 2017-09-20 19:47:22,213 INFO  [main] o.a.j.o.segment.file.FileStore - Creating file store
FileStoreBuilder{version=1.7.7, directory=/path/to/repository/segmentstore, blobStore=DataStore
backed BlobStore [org.apache.jackrabbit.oak.plugins.blob.datastore.OakFileDataStore], maxFileSize=256,
segmentCacheSize=256, stringCacheSize=256, templateCacheSize=64, stringDeduplicationCacheSize=15000,
templateDeduplicationCacheSize=3000, nodeDeduplicationCacheSize=1048576, memoryMapping=true,
gcOptions=SegmentGCOptions{paused=false, estimationDisabled=false, gcSizeDeltaEstimation=1073741824,
retryCount=5, forceTimeout=60, retainedGenerations=2, gcType=FULL}} 
> 2017-09-20 19:47:22,243 WARN  [main] o.a.j.o.s.file.tar.TarReader - Unable to load index
of file data00000a.tar: Unrecognized magic number 
> 2017-09-20 19:47:22,243 INFO  [main] o.a.j.o.s.file.tar.TarReader - No index found in
tar file data00000a.tar, skipping... 
> 2017-09-20 19:47:22,243 WARN  [main] o.a.j.o.s.file.tar.TarReader - Could not find a
valid tar index in /path/to/repository/segmentstore/data00000a.tar, recovering read-only 
> 2017-09-20 19:47:22,243 INFO  [main] o.a.j.o.s.file.tar.TarReader - Recovering segments
from tar file /path/to/repository/segmentstore/data00000a.tar 
> 2017-09-20 19:47:22,315 INFO  [main] o.a.j.o.s.file.tar.TarReader - Regenerating tar
file/path/to/repository/segmentstore/data00000a.tar.ro.bak 
> 2017-09-20 19:47:22,460 ERROR [main] o.a.j.oak.index.IndexCommand - Error occurred while
performing index tasks 
> java.lang.IllegalArgumentException: invalid segment buffer
> 	at org.apache.jackrabbit.oak.segment.data.SegmentDataLoader.newSegmentData(SegmentDataLoader.java:37)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.data.SegmentData.newSegmentData(SegmentData.java:66)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.AbstractFileStore.writeSegment(AbstractFileStore.java:212)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.AbstractFileStore.access$000(AbstractFileStore.java:66)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.AbstractFileStore$1.recoverEntry(AbstractFileStore.java:125)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.tar.TarReader.generateTarFile(TarReader.java:213)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.tar.TarReader.openRO(TarReader.java:162) ~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.tar.TarFiles.<init>(TarFiles.java:298)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.tar.TarFiles.<init>(TarFiles.java:58)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.tar.TarFiles$Builder.build(TarFiles.java:167)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.ReadOnlyFileStore.<init>(ReadOnlyFileStore.java:74)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.segment.file.FileStoreBuilder.buildReadOnly(FileStoreBuilder.java:383)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.run.cli.SegmentTarFixtureProvider.configureSegment(SegmentTarFixtureProvider.java:63)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.run.cli.NodeStoreFixtureProvider.create(NodeStoreFixtureProvider.java:71)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.run.cli.NodeStoreFixtureProvider.create(NodeStoreFixtureProvider.java:47)
~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.index.IndexCommand.execute(IndexCommand.java:98) ~[oak-run-1.7.7.jar:1.7.7]
> 	at org.apache.jackrabbit.oak.run.Main.main(Main.java:49) [oak-run-1.7.7.jar:1.7.7]
> {noformat}
> Post restart of server oak-run was able to connect fine. So looks like issue with very
fresh setup only
> Command used for oak-run
> {noformat}
> java -jar oak-run-1.7.7.jar index --fds-path=/path/to/repository/datastore --checkpoint
head --reindex --index-paths=/oak:index/lucene /path/to/repository/segmentstore --metrics
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message