jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Mueller (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-6735) Lucene Index: improved cost estimation by using document count per field
Date Fri, 03 Nov 2017 09:25:00 GMT

    [ https://issues.apache.org/jira/browse/OAK-6735?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16237342#comment-16237342

Thomas Mueller commented on OAK-6735:

> Unfortunately, we don't have a good escape mechanism while naming fields

Yes, I see. It's just something to remember next time: don't just append "_facet" or so, as
it might collide with a real property name. Make sure there can be no collisions, for example
by using the ":" prefix.

For now, I'm afraid the only thing we can do is cross fingers that nobody is every going to
use property names ending with "_facet".

> field name like "synthetically-falliable-field" 

Yes, looks much better now.

> Lucene Index: improved cost estimation by using document count per field
> ------------------------------------------------------------------------
>                 Key: OAK-6735
>                 URL: https://issues.apache.org/jira/browse/OAK-6735
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: lucene, query
>    Affects Versions: 1.7.4
>            Reporter: Thomas Mueller
>            Assignee: Vikas Saurabh
>            Priority: Major
>              Labels: doc-impacting
>             Fix For: 1.8, 1.7.11
>         Attachments: IndexReadPattern.txt, LuceneIndexReadPattern.java, OAK-6735.patch
> The cost estimation of the Lucene index is somewhat inaccurate because (by default) it
just used the number of documents in the index (as of Oak 1.7.4 by default, due to OAK-6333).
> Instead, it should use the number of documents for the given fields (the minimum, if
there are multiple fields with restrictions). 
> Plus divided by the number of restrictions (as we do now already).

This message was sent by Atlassian JIRA

View raw message