jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] [Commented] (OAK-3855) oak-run compact should check segment version
Date Mon, 18 Dec 2017 10:44:00 GMT

    [ https://issues.apache.org/jira/browse/OAK-3855?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16294782#comment-16294782
] 

Michael Dürig commented on OAK-3855:
------------------------------------

[~volteanu], I'll follow up on, where your comment applies for Oak 1.8.

> oak-run compact should check segment version
> --------------------------------------------
>
>                 Key: OAK-3855
>                 URL: https://issues.apache.org/jira/browse/OAK-3855
>             Project: Jackrabbit Oak
>          Issue Type: Technical task
>          Components: run
>            Reporter: Michael Dürig
>            Assignee: Michael Dürig
>            Priority: Critical
>              Labels: gc, resilience, tooling
>             Fix For: 1.3.15, 1.4
>
>
> Off line compaction should exit with a warning if run on a store with non matching segment
version. It should provide a {{--force}} option to override this behaviour such that it can
still be used for explicit upgrading. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message