jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] [Commented] (OAK-6625) Avoid oak-run compact inadvertently upgrading the segment format
Date Mon, 18 Dec 2017 10:44:00 GMT

    [ https://issues.apache.org/jira/browse/OAK-6625?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16294784#comment-16294784
] 

Michael Dürig commented on OAK-6625:
------------------------------------

Re. https://issues.apache.org/jira/browse/OAK-3855?focusedCommentId=16294770&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-16294770:
No {{-force}} is not yet mentioned in {{oak-docs}}. I'll fix this.

> Avoid oak-run compact inadvertently upgrading the segment format 
> -----------------------------------------------------------------
>
>                 Key: OAK-6625
>                 URL: https://issues.apache.org/jira/browse/OAK-6625
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: run, segment-tar
>            Reporter: Michael Dürig
>            Assignee: Michael Dürig
>              Labels: gc, production, resilience
>             Fix For: 1.7.7, 1.8
>
>
> The transparent upgrade feature for segments from version 12 to 13 should not cause "accidental
upgrades". That is, running Oak 1.8 oak-run compact on a store with segment version 12 should
bail out unless a special option was specified on the command line. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message