jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Francesco Mari (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OAK-7064) Remove duplicated code from the FileStore logging implementation
Date Fri, 15 Dec 2017 09:14:00 GMT

     [ https://issues.apache.org/jira/browse/OAK-7064?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Francesco Mari updated OAK-7064:
    Attachment: OAK-7064-02.patch

In the second version of the patch I remove the default method from {{GCListener}} and create
an equivalent implementation {{PrefixedGCListener}}. I tried to encapsulate {{GC_COUNT}} in
{{PrefixedGCListener}}, but I failed to do so because {{GC_COUNT}} is also used in {{FileStore.CompactionResult#gcInfo}}.
This is the only other usage of {{GC_COUNT}} outside of the logging code, but I guess we can't
get rid of that.

> Remove duplicated code from the FileStore logging implementation
> ----------------------------------------------------------------
>                 Key: OAK-7064
>                 URL: https://issues.apache.org/jira/browse/OAK-7064
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: segment-tar
>            Reporter: Francesco Mari
>            Assignee: Francesco Mari
>            Priority: Minor
>             Fix For: 1.7.13, 1.8
>         Attachments: OAK-7064-01.patch, OAK-7064-02.patch
> The {{FileStore}} follows some implicit guidelines when it comes to its logging messages,
e.g. prefixing every message with the GC cycle number, and outputting times and sizes both
in a human readable and machine readable way.
> These guidelines are implemented ad-hoc, by appropriately crafting each log message individually.
This approach leads to clutter and duplicated code. It would be beneficial to the internal
quality of the {{FileStore}} if all these concerns were instead implemented in a centralised

This message was sent by Atlassian JIRA

View raw message