jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davide Giannella (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (OAK-6976) CopyOnWriteDirectory_Segment_Test failure
Date Thu, 04 Jan 2018 11:38:00 GMT

     [ https://issues.apache.org/jira/browse/OAK-6976?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Davide Giannella updated OAK-6976:
----------------------------------
    Fix Version/s: 1.4.20

> CopyOnWriteDirectory_Segment_Test failure
> -----------------------------------------
>
>                 Key: OAK-6976
>                 URL: https://issues.apache.org/jira/browse/OAK-6976
>             Project: Jackrabbit Oak
>          Issue Type: Bug
>          Components: lucene
>    Affects Versions: 1.4.18
>            Reporter: Marcel Reutegger
>            Assignee: Chetan Mehrotra
>             Fix For: 1.0.40, 1.4.19, 1.2.28, 1.4.20
>
>
> This test only exists in branches 1.4 and older and was introduced as part of OAK-5238.
The test fails every now and then with (stack trace from 1.4):
> {noformat}
> java.lang.IllegalStateException: This builder does not exist: child-0
> 	at com.google.common.base.Preconditions.checkState(Preconditions.java:150)
> 	at org.apache.jackrabbit.oak.plugins.memory.MemoryNodeBuilder.setProperty(MemoryNodeBuilder.java:506)
> 	at org.apache.jackrabbit.oak.plugins.memory.MemoryNodeBuilder.setProperty(MemoryNodeBuilder.java:515)
> 	at org.apache.jackrabbit.oak.plugins.index.lucene.CopyOnWriteDirectory_Segment_Test.writeTree(CopyOnWriteDirectory_Segment_Test.java:158)
> 	at org.apache.jackrabbit.oak.plugins.index.lucene.CopyOnWriteDirectory_Segment_Test.copyOnWrite(CopyOnWriteDirectory_Segment_Test.java:111)
> {noformat}
> Please note that it fails more likely when the update.limit is set to 100, which is the
case for the maven build.
> I also ported the test to 1.6 and running it with the new segment-tar looks OK. I don't
know if this is because the copy-on-write or the segment-tar implementation is different than
in 1.4. 
> The affected versions are currently only set to 1.4.18, because there were no releases
off the 1.2 and 1.0 branches since OAK-5238 was backported.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message