jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Reutegger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-7603) [DirectBinaryAccess][DISCUSS] Oak API extensions
Date Wed, 25 Jul 2018 12:39:00 GMT

    [ https://issues.apache.org/jira/browse/OAK-7603?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16555581#comment-16555581
] 

Marcel Reutegger commented on OAK-7603:
---------------------------------------

[~mattvryan], I added some JavaDoc to the interfaces in oak-api. See my changes here: https://github.com/mattvryan/jackrabbit-oak/compare/direct-binary-access-v2-with-GCTest...mreutegg:OAK-7603

I was also wondering if we should rename those interfaces (again, I know) and remote 'direct'
in the names. That is, {{BlobDirectAccessProvider}} would become {{BlobAccessProvider}} and
its methods changed from {{initiateDirectUpload()}} to {{initiateBlobUpload()}} and {{completeDirectUpload()}}
to {{completeBlobUpload()}}. It would be more in line with the naming we use in Jackrabbit
API. WDYT?

Otherwise the package is in good shape and I would like to commit it soon separately from
the remaining part of the PR.

> [DirectBinaryAccess][DISCUSS] Oak API extensions
> ------------------------------------------------
>
>                 Key: OAK-7603
>                 URL: https://issues.apache.org/jira/browse/OAK-7603
>             Project: Jackrabbit Oak
>          Issue Type: Technical task
>          Components: api
>            Reporter: Marcel Reutegger
>            Assignee: Matt Ryan
>            Priority: Major
>
> Review and discuss the API extensions in oak-api. If desired these changes can be committed
before the implementation is ready.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message