jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Reschke (Jira)" <j...@apache.org>
Subject [jira] [Comment Edited] (OAK-8798) Upgrade maven-bundle-plugin to 4.2.1
Date Mon, 02 Dec 2019 13:51:00 GMT

    [ https://issues.apache.org/jira/browse/OAK-8798?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16986059#comment-16986059
] 

Julian Reschke edited comment on OAK-8798 at 12/2/19 1:50 PM:
--------------------------------------------------------------

Potential change: [^OAK-8798.diff]

So the interesting problem here is that the new bundle plugin uses a newer version of bndlib,
and that leads to different Import-Package declarations in the pom.xml. This can be addressed
as seen in the patch, but I'm not sure whether it's the right thing to do (without the suppressed
imports, the bundle will fail in oak-it-osgi).

 

[~teofili] - help appreciated.


was (Author: reschke):
Potential change: [^OAK-8798.diff]

So the interesting problem here is that the new bundle plugin uses a newer version of bndlib,
and that leads to different Import-Package declarations in the pom.xml. This can be addressed
as seen in the patch, but I'm not sure whether it's the right thing to do (without the suppressed
imports, the bundle will fail in oak-it-osgi).

> Upgrade maven-bundle-plugin to 4.2.1
> ------------------------------------
>
>                 Key: OAK-8798
>                 URL: https://issues.apache.org/jira/browse/OAK-8798
>             Project: Jackrabbit Oak
>          Issue Type: Task
>          Components: parent
>            Reporter: Julian Reschke
>            Assignee: Julian Reschke
>            Priority: Minor
>              Labels: candidate_oak_1_10
>             Fix For: 1.22.0
>
>         Attachments: OAK-8798.diff
>
>




--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message