jakarta-bcel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dbros...@baybroadband.net
Subject FW: [jira] Commented: (XALANJ-2196) Unneeded BCEL classes in Xalan.jar (2 jar version)
Date Wed, 11 Jan 2006 16:35:49 GMT
FYI

----- Original Message -----
From: "Eric Everman (JIRA)" <xalan-dev@xml.apache.org>
Sent: Wednesday, January 11, 2006 10:35 am
To: xalan-dev@xml.apache.org
Subject: [jira] Commented: (XALANJ-2196) Unneeded BCEL classes in
Xalan.jar (2 jar version)

    [
http://issues.apache.org/jira/browse/XALANJ-2196?page=comments#action_12362455
]

Eric Everman commented on XALANJ-2196:
--------------------------------------

I'd like to add a (mild) sense of urgency to this:

While applications are expecting XML/XSLT parsers to be swapped, they are
not expecting versions of BCEL to be swaped.  Last I tried, placing the
xalan.jar on the class path of Oracle's OC4J (a J2EE application server)
bombed the entire server because of clashing BCEL versions.

I've managed to force this to work by futzing with a custom build, but I
think its safe to say that anyone running a framework that makes use of
BCEL is essentially cut-off from this version of Xalan.  Could this patch
possibly be included in a dot release?

Thanks Much!

> Unneeded BCEL classes in Xalan.jar (2 jar version)
> --------------------------------------------------
>
>          Key: XALANJ-2196
>          URL: http://issues.apache.org/jira/browse/XALANJ-2196
>      Project: XalanJ2
>         Type: Bug
>   Components: Xalan
>     Versions: 2.7
>  Environment: All
>     Reporter: Eric Everman
>     Assignee: Sarah McNamara
>  Attachments: XALANJ-2196.patch.txt
>
> The binary '2 jar' distribution of Xalan includes the BCEL classes in
the xalan.jar.  These classes are not required for Xalan, only for
XMLTC.  I marked this bug as 'major' because it prevents xalan 2.7 from
being used under Oracle's OC4J J2EE web container, which relies on an
older version of BCEL and will crash if the newer version is on the
classpath. Note that I was able to get the 2.7 version of xalan to work
under OC4J by using a non-public portion of the ant build script to
build the xalan.jar without BCEL. This thread on the user's discussion
list has slightly more information then this post:
http://marc.theaimsgroup.com/?l=xalan-j-users&m=112597125332553
> Sarah McNamara claims to have a patch available.
> Thanks Much,
> Eric Everman

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


--------------------------------------------------------------------- To
unsubscribe, e-mail: xalan-dev-unsubscribe@xml.apache.org
For additional commands, e-mail: xalan-dev-help@xml.apache.org







---------------------------------------------------------------------
To unsubscribe, e-mail: bcel-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: bcel-dev-help@jakarta.apache.org


Mime
View raw message