jakarta-bsf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor J. Orlikowski" <victor.j.orlikow...@alumni.duke.edu>
Subject Re: [FWD] [GUMP] Build Failure - dist-ant
Date Tue, 08 Jul 2003 18:29:36 GMT
On Tue, Jul 08, 2003 at 04:57:34PM +0200, Stefan Bodewig wrote:
> On Tue, 8 Jul 2003, Victor J. Orlikowski
> <victor.j.orlikowski@alumni.duke.edu> wrote:
> 
> > Hence, the BSFManager exec() method should now take the language
> > and script parameters only, as was the case in 2.2.
> 
> Neither 2.2 nor 2.3.0-rc have a two-arg version of BSFManager#exec.
> If I change Ant to pass only two arguments, Ant will not compile
> against any released version of BSF.
> 
> Maybe you could put the five arg versions of eval, exec and apply back
> in (deprecated off course) and ignore arguments two to five?  This
> would give us a migration phase until 2.3.0 final has been released -
> after which we'll happily change our invocation.
> 
> See the patch below, if you like the idea.
> 
>         Stefan

Stefan, Howard:

Ugh, quite right. Neither had the two-arg version. My mistake.

OK, I'm perfectly amenable to putting back the 5-arg versions, and
marking them as deprecated; your patch covers that, Stefan, though
I may make minor changes (prolly not many).

My intent was to bring the parameter lists back in line w/ those
in 2.2; I'll do a quick bit of research to see what I missed, and
put that back.

That should get both Tapestry and Ant back straight till the next
release.

Cool with everyone involved?

Victor
-- 
Victor J. Orlikowski  | The Wall is Down, But the Threat Remains!
=================================================================
orlikowski@apache.org | victor.j.orlikowski@alumni.duke.edu

Mime
View raw message