jakarta-bsf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rony G. Flatscher" <Rony.Flatsc...@wu-wien.ac.at>
Subject Re: NetRexx 2.x / BSF2.3 issue getting "current" BSFManager instance...
Date Fri, 10 Jan 2003 07:55:20 GMT
Keith:

> I've tried the syntax in the example, in fact I just tried
> it again to make sure, and NetRexxC chokes on
> the reference to bsf.  It cannot resolve it.   The only
> thing I'm importing other than my own stuff is:
>
>      import org.apache.bsf.BSFManager
>
> though, so maybe I'm missing something.  I've also
> tried skipping the lookupBean() all together, which is
> what the docs suggest you should be able to do when
> you call declareBean() from Java.  This also fails.
>
> Clearly I'm missing something, but your examples
> look very interesting, and maybe looking thru that
> will help.
>

Hmm, maybe (just a guess) your NetRexx scripts are not invoked via BSF?

This is what you would need to do to invoke a standalone NetRexx program from a Windows command
line for IBM's BSF:

    java com.ibm.bsf.Main -mode exec -lang netrexx -in %1

Just adapt the package name to Apache's.

If it's the first time you use BSF then you might skim over this article:

> <http://wi.wu-wien.ac.at/rgf/rexx/orx12/JavaBeanScriptingWithRexx_orx12.pdf>)
>

Also, the enhanced version of my bsf4rexx (to be ported to Apache BSF) for alpha testing (including
sources and samples)
can be downloaded from:

    http://wi.wu-wien.ac.at/rgf/rexx/bsf4rexx/

Eventually this version will be moved to sourceforge for those people who have the IBM version
deployed.

Hope that helps,

---rony



Mime
View raw message